Re: Coolkey fails to build on Leopard

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Thanks for looking into this.

First of all, have you been able to get it to build on Tiger?

The instructions (albeit somewhat involved) are here: The instructions tell one how to do a universal binary build. We've gotten it to work on both ppc and i386.

I took a look at the config.log and it's complaining about finding crt10.5.o missing.

1. Is it possible that you don't have the 10.4u developer framework?

2. I did some googling and the following exchange looks like this might be our problem.

I think this rises to the level of a bug.

I suppose you can choose Fedora and "coolkey" as the component.


David Mueller wrote:
I would have filed this as a bug in Bugzilla, but I couldn't figure out where. Most of the Coolkey bugs seemed to be filed under Fedora or RHEL, which seemed inappropriate for a Mac OS X issue. I couldn't figure out which product/component under Dogtag to use, either.

Earlier this week I was trying to build Coolkey from source on Mac OS X 10.5.2 (Leopard) and ./configure failed. I initially tried on an Intel machine using the 1.1.0 release tarball and that didn't work, and I got the same issue with CVS. Also tried using the CVS source on PowerPC and it didn't work either. This is what I get:

$ ./configure --disable-dependency-tracking
checking build system type... powerpc-apple-darwin9.2.2
checking host system type... powerpc-apple-darwin9.2.2
checking target system type... powerpc-apple-darwin9.2.2
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking platform type: ... MAC
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

I'm attaching the config.log as well. If anyone (Bob or Bob?) want me to file this in Bugzilla, just let me know where. :)

- David


Coolkey-devel mailing list

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux