> diff --git a/storage/udev.py b/storage/udev.py > index 2b3d47a..2147aca 100644 > --- a/storage/udev.py > +++ b/storage/udev.py > @@ -259,7 +259,7 @@ def udev_device_get_wwid(udev_info): > colons in the name to make it more readable. """ > serial = udev_device_get_serial(udev_info) > > - if len(serial) == 32: > + if serial and len(serial) == 32: > retval = "" > for i in range(0, 16): > retval += serial[i*2:i*2+2] + ":" This is probably fine. However, what we need to do is sit down and come to a consensus about what in storage/udev.py should raise exceptions and what should not. - Chris _______________________________________________ Anaconda-devel-list mailing list Anaconda-devel-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/anaconda-devel-list