Hi,
On 07/08/2009 04:29 PM, David Lehman wrote:
On Wed, 2009-07-08 at 15:56 +0200, Hans de Goede wrote:
---
storage/devices.py | 9 ++++++---
storage/devicetree.py | 14 ++++++++------
storage/udev.py | 9 ++++++---
3 files changed, 20 insertions(+), 12 deletions(-)
I have one minor nit, below.
diff --git a/storage/devicetree.py b/storage/devicetree.py
index 6a1ad61..91a9f4b 100644
--- a/storage/devicetree.py
+++ b/storage/devicetree.py
@@ -888,8 +888,10 @@ class DeviceTree(object):
return True
# Ignore partitions found on the raw disks which are part of a
- # dmraidset
- for set in self.getDevicesByType("dm-raid array"):
+ # biosraidset
+ sets = self.getDevicesByType("dm-raid array")
+ sets[len(sets):] = self.getDevicesByType("mdcontainer")
For readability, it would be nice to change this to:
sets.extend(self.getDevicesByType("mdcontainer"))
I tried that but if both the sets are empty, extend
returns None instead of [] (yeah that sucks).
Regards,
Hans
_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/anaconda-devel-list