Re: [PATCH 6/6] xfs: rename XFS_BUF_ZEROFLAGS macro

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Feb 09, 2016 at 09:31:20AM +1100, Dave Chinner wrote:
> > xlog_sync already sets a lot of these flags again, and is called on an
> > iclog buffer which never has the READ or XBF_WRITE_FAIL set, so just
> > replacing it with an opencoded
> > 
> > 	bp->b_flags &= (XBF_FUA | XBF_FLUSH);
> 
> We can't do that because there are internal flags like _XBF_PAGES
> that are set on log buffers. Clearing such flags will cause problems
> when the iclog buffer is finally released on unmount. Hence I'd
> prefer to keep the code as it stands.

Sorry - meabt to write:

	bp->b_flags &= ~(XBF_FUA | XBF_FLUSH);

which is all we'll need.  All other flags cleared by XFS_BUF_ZEROFLAGS
are either never set for log buffers (XBF_READ, XBF_WRITE_FAIL), or
always set for log buffers (XBF_WRITE, XBF_ASYNC, XBF_SYNCIO).

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs



[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux