Instead of just renaming it I'd rather dig deeper. In xlog_bwrite we call xfs_bwrite, which already handles all flag clearing, so the call to XFS_BUF_ZEROFLAGS can just be removed. xlog_sync already sets a lot of these flags again, and is called on an iclog buffer which never has the READ or XBF_WRITE_FAIL set, so just replacing it with an opencoded bp->b_flags &= (XBF_FUA | XBF_FLUSH); for both instances should be enough, and even that could be moved into and else clause of the if (log->l_mp->m_flags & XFS_MOUNT_BARRIER) conditional. _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs