On Sun, Feb 08, 2015 at 12:45:04PM +0800, Wang Sheng-Hui wrote: > The beginning is about magic and version number check. > Move the comment on log device near the log dev check logic. > > Signed-off-by: Wang Sheng-Hui <shhuiw@xxxxxxxxxxx> The comment is old and redundant. The error messages document the reason for the checks better than the comment and the comments about volume mounts date back to Irix and so aren't relevant any more. So just remove the comment. > --- > fs/xfs/libxfs/xfs_sb.c | 17 +++++++++-------- > 1 file changed, 9 insertions(+), 8 deletions(-) > > diff --git a/fs/xfs/libxfs/xfs_sb.c b/fs/xfs/libxfs/xfs_sb.c > index 752915f..b4bb852 100644 > --- a/fs/xfs/libxfs/xfs_sb.c > +++ b/fs/xfs/libxfs/xfs_sb.c > @@ -174,20 +174,13 @@ xfs_mount_validate_sb( > bool check_inprogress, > bool check_version) > { > + /* check magic number and version number */ No need to add a redundant comment - it is obvious what the code it refers to is checking. Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs