creating vlans on diskless system

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I am trying to use vconfig to create a VLAN on a diskless (NFS-rooted) system, after it has booted from a server via PXE.

The boot is via eth0, and I want to add the VLAN to eth0 as well.

As soon as I run "vconfig add eth0 101" (for example) the eth0 network link goes down. This is rather problematic because at that point NFS is no longer working of course, so nothing is working and I cannot debug the situation .....

Believing that it might have something to do with dynamic libraries being accessed while the eth0 interface is being reconfigured by vconfig, I created a statically linked version of vconfig, copied that to a RAM-disk on the diskless machine, but I get the same problem: as soon as I run vconfig eth0 goes down and my cursor hangs due to no more NFS support.

What could be wrong, and how can I debug this?


Vlan mailing list

[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]     [Video 4 Linux]

  Powered by Linux