Re: [PATCH 1/8] portability: add checks in configure script

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Jul 20, 2010 at 07:11:16PM +0200, François Revol wrote:
> add checks in configure script for headers and types, and options to disable some more util groups and individual utils.

 It would be really better to split this patch (one patch for each
 new configure option).

+AC_ARG_ENABLE([swap],
+  AS_HELP_STRING([--disable-swap], [do not build swap utilities]),
+  [], enable_swap=check
+)

Please, rename this to --disable-mkswap and BUILD_MKSWAP

Why do you need --disable-swap and also --disable-disk? The mkswap is
part of disk utils.

+AC_ARG_ENABLE([ipcs],
+  AS_HELP_STRING([--disable-ipcs], [do not build ipcs]),
+  [], enable_ipcs=check
+)

 What about --disable-ipc-utils ?

+AC_ARG_ENABLE([disk],
+  AS_HELP_STRING([--disable-disk], [do not build disk utilities]),
+  [], enable_disk=yes
+)

 What about --disable-disk-utils ?

    Karel

-- 
 Karel Zak  <kzak@xxxxxxxxxx>
 http://karelzak.blogspot.com
--
To unsubscribe from this list: send the line "unsubscribe util-linux-ng" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]

  Powered by Linux