On Thu, Nov 06, 2008 at 04:52:13PM +0000, Américo Wang wrote: > > foo > [ "$?" == "0" ] || bar > > can be replaced by: > > foo || bar Well, from my C-like point of view ;-) is the original version more readable, but I have no a strong opinion about it. Please, fix the patch: > -$TS_CMD_UMOUNT $DEVICE > -[ "$?" == "0" ] || ts_die "A) Cannot umount $DEVICE" $DEVICE > + || ts_die "A) Cannot found $DEVICE in /proc/mounts" $DEVICE ^^^ syntax error, you need to use foo || \ die "foo failed" > + || ts_die "B) Cannot found $DEVICE in /proc/mounts" $DEVICE ... > + || ts_die "Cannot found LABEL '$LABEL' on $DEVICE" $DEVICE ... etc. Please, test the patch next time. Karel -- Karel Zak <kzak@xxxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe util-linux-ng" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html