On Wed, Apr 18, 2018 at 1:15 AM, Sascha Hauer <s.hauer@xxxxxxxxxxxxxx> wrote: > On Tue, Apr 17, 2018 at 08:20:46AM -0700, Andrey Smirnov wrote: >> On Mon, Apr 16, 2018 at 11:58 PM, Sascha Hauer <s.hauer@xxxxxxxxxxxxxx> wrote: >> > On Mon, Apr 16, 2018 at 12:31:39PM -0700, Andrey Smirnov wrote: >> >> All of the instances of imx*_boot_save_loc() do exactly the same thing with >> >> the only difference being SoC-specific imx*_get_boot_source >> >> call. Convert the code into a generic function taking function pointer >> >> + a macro to take care of the boilerplate. >> >> >> >> Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx> >> >> --- >> >> arch/arm/mach-imx/boot.c | 85 ++++++++++-------------------------------------- >> >> 1 file changed, 17 insertions(+), 68 deletions(-) >> >> >> >> +imx_boot_save_loc(void (*get_boot_source)(enum bootsource *, int *)) >> >> { >> >> enum bootsource src = BOOTSOURCE_UNKNOWN; >> >> int instance = BOOTSOURCE_INSTANCE_UNKNOWN; >> >> >> >> - imx7_get_boot_source(&src, &instance); >> >> + get_boot_source(&src, &instance); >> >> >> >> bootsource_set(src); >> >> bootsource_set_instance(instance); >> >> } >> >> + >> >> +#define IMX_BOOT_SAVE_LOC(soc) \ >> >> + void soc##_boot_save_loc(void) \ >> >> + { \ >> >> + imx_boot_save_loc(soc##_get_boot_source); \ >> >> + } >> >> + >> >> +IMX_BOOT_SAVE_LOC(imx25) >> >> +IMX_BOOT_SAVE_LOC(imx27) >> >> +IMX_BOOT_SAVE_LOC(imx35) >> >> +IMX_BOOT_SAVE_LOC(imx51) >> >> +IMX_BOOT_SAVE_LOC(imx53) >> >> +IMX_BOOT_SAVE_LOC(imx6) >> >> +IMX_BOOT_SAVE_LOC(imx7) >> > >> > I do not really like this patch. Yes, it saves a few lines of code, but >> > with the cost of making it less readable. >> > >> >> Can you elaborate on what part is less readable? IMHO, replacing 68 >> line of mostly copy pasted code with 17 of a generic function is a bit >> more than "saving a few lines of code", so I think it's worth trying >> to find a solution that would be acceptable from both perspectives: >> conciseness and readability. > > I think it's bad when grepping for a function name only reveals the > callers, maybe the declaraion, but not the definition of a function. > Using macros to define functions is sometimes very effective (and done > in barebox at other places), but not very nice to look at. > >> >> Would replacing function pointer with a switch (imx_cpu_type) and >> expanding IMX_BOOT_SAVE_LOC() make this patch readable enough to be >> accepted? > > Not sure what exactly you mean, but the following should be fine. With > a bit of violating the coding style this is not longer than your solution, > but without hiding the function names behind a macro: > > void vf610_boot_save_loc(void) { boot_save_loc(vf610_get_boot_source); } > That's what I meant by "expanding IMX_BOOT_SAVE_LOC()". I'll update the patch and re-submit it. Thanks, Andrey Smirnov _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox