On Mon, Apr 16, 2018 at 12:31:39PM -0700, Andrey Smirnov wrote: > All of the instances of imx*_boot_save_loc() do exactly the same thing with > the only difference being SoC-specific imx*_get_boot_source > call. Convert the code into a generic function taking function pointer > + a macro to take care of the boilerplate. > > Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx> > --- > arch/arm/mach-imx/boot.c | 85 ++++++++++-------------------------------------- > 1 file changed, 17 insertions(+), 68 deletions(-) > > +imx_boot_save_loc(void (*get_boot_source)(enum bootsource *, int *)) > { > enum bootsource src = BOOTSOURCE_UNKNOWN; > int instance = BOOTSOURCE_INSTANCE_UNKNOWN; > > - imx7_get_boot_source(&src, &instance); > + get_boot_source(&src, &instance); > > bootsource_set(src); > bootsource_set_instance(instance); > } > + > +#define IMX_BOOT_SAVE_LOC(soc) \ > + void soc##_boot_save_loc(void) \ > + { \ > + imx_boot_save_loc(soc##_get_boot_source); \ > + } > + > +IMX_BOOT_SAVE_LOC(imx25) > +IMX_BOOT_SAVE_LOC(imx27) > +IMX_BOOT_SAVE_LOC(imx35) > +IMX_BOOT_SAVE_LOC(imx51) > +IMX_BOOT_SAVE_LOC(imx53) > +IMX_BOOT_SAVE_LOC(imx6) > +IMX_BOOT_SAVE_LOC(imx7) I do not really like this patch. Yes, it saves a few lines of code, but with the cost of making it less readable. Sascha -- Pengutronix e.K. | | Industrial Linux Solutions | http://www.pengutronix.de/ | Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 | _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox