On Thu, Oct 03, 2013 at 09:21:54AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote: > rename it to console_get_by_name > > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@xxxxxxxxxxxx> > --- > +struct console_device *console_get_by_name(const char *cname) > +{ > + struct console_device *cdev; > + const char *target; > + > + for_each_console(cdev) { > + target = dev_id(&cdev->class_dev); > + if (strcmp(cname, target)) > + continue; > + if ((cdev->f_active & (CONSOLE_STDIN | CONSOLE_STDOUT)) > + return cdev; > + return NULL; > + } > + return NULL; > +} > +EXPORT_SYMBOL(console_get_by_name); I think this function should return the console regardless of whether it's active or not. This makes the console_get_by_name_flags you introduce later unnecessary. Also the loadxyz code shouldn't care if it's activated but instead just activate the console if necessary. Sascha -- Pengutronix e.K. | | Industrial Linux Solutions | http://www.pengutronix.de/ | Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 | _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox