Hi Bart, So after going patch by patch, issue by issue through -v4 of your proposed series, I've still got a number of concerns that I want to see addressed before considering the significant code changes you've proposed that effect many different areas of target-core, and it's interaction with in-tree fabric drivers. As mentioned, these significant of changes require a significant amount of focused Q/A regression testing before getting into mainline. I haven't seen that happening so far, considering how easy it was to break the series with even the most trivial of first order TMR tests. That said, I've gone through your for-next tree and picked up the patches that I'm comfortable with stability and review wise, and included them into target-pending/for-next for consideration. Certainly, these will conflict with what you've put in your own for-next tree, but given how little testing and missing reviews the complete series has, I'm OK with dealing with that conflict if you would rather try to force the issue with upstream. That said, based on the individual -v4 patches you posted, here is the list that I've included into target-pending/for-next. Please review, or feel free to comment on the individual patches that you think should be included beyond what's below. Thank you, --nab Bart Van Assche (17): qla2xxx: Avoid using variable-length arrays target/cxgbit: Fix endianness annotations target/tcm_fc: Remove a set-but-not-used variable target/iscsi: Fix indentation in iscsi_target_start_negotiation() target/iscsi: Fix spelling of "perform" target/iscsi: Fix spelling of "reallegiance" target/iscsi: Introduce a helper function for TMF translation target/iscsi: Fix iSCSI task reassignment handling target: Remove se_tmr_req.tmr_lun target: Make core_tmr_abort_task() consider all commands target: Correct transport_wait_for_tasks() documentation target: Stop execution if CMD_T_STOP has been set target: Remove an overly chatty debug message target: Inline transport_cmd_check_stop() target: Move session check from target_put_sess_cmd() into target_release_cmd_kref() target: Remove command flag CMD_T_BUSY qla2xxx: Remove SRR code qla2xxx: Remove unused reverse_ini_mode Joe Carnuccio (1): qla2xxx: Simplify usage of SRB structure in driver Quinn Tran (9): qla2xxx: Remove direct access of scsi_status field in se_cmd qla2xxx: Cleanup TMF code translation from qla_target qla2xxx: Make trace flags more readable qla2xxx: Fix wrong argument in sp done callback qla2xxx: Use d_id instead of s_id for more clarity qla2xxx: Track I-T nexus as single fc_port struct qla2xxx: Add framework for async fabric discovery qla2xxx: Add Dual mode support in the driver qla2xxx: Improve RSCN handling in driver Varun Prakash (1): target/cxgbit: Use T6 specific macro to set the force bit drivers/net/ethernet/chelsio/cxgb4/t4_msg.h | 4 + drivers/net/ethernet/chelsio/libcxgb/libcxgb_ppm.h | 2 +- drivers/scsi/qla2xxx/qla_attr.c | 3 + drivers/scsi/qla2xxx/qla_bsg.c | 23 +- drivers/scsi/qla2xxx/qla_def.h | 306 ++- drivers/scsi/qla2xxx/qla_dfs.c | 11 +- drivers/scsi/qla2xxx/qla_fw.h | 106 +- drivers/scsi/qla2xxx/qla_gbl.h | 72 +- drivers/scsi/qla2xxx/qla_gs.c | 726 +++++- drivers/scsi/qla2xxx/qla_init.c | 1612 +++++++++---- drivers/scsi/qla2xxx/qla_inline.h | 18 +- drivers/scsi/qla2xxx/qla_iocb.c | 167 +- drivers/scsi/qla2xxx/qla_isr.c | 317 ++- drivers/scsi/qla2xxx/qla_mbx.c | 232 +- drivers/scsi/qla2xxx/qla_mr.c | 48 +- drivers/scsi/qla2xxx/qla_os.c | 330 ++- drivers/scsi/qla2xxx/qla_target.c | 2392 +++++++++----------- drivers/scsi/qla2xxx/qla_target.h | 252 +-- drivers/scsi/qla2xxx/tcm_qla2xxx.c | 256 ++- drivers/scsi/qla2xxx/tcm_qla2xxx.h | 4 +- drivers/target/iscsi/cxgbit/cxgbit_cm.c | 11 +- drivers/target/iscsi/cxgbit/cxgbit_main.c | 2 +- drivers/target/iscsi/cxgbit/cxgbit_target.c | 6 +- drivers/target/iscsi/iscsi_target.c | 73 +- drivers/target/iscsi/iscsi_target_erl2.c | 6 +- drivers/target/iscsi/iscsi_target_erl2.h | 2 +- drivers/target/iscsi/iscsi_target_login.c | 2 +- drivers/target/iscsi/iscsi_target_nego.c | 16 +- drivers/target/iscsi/iscsi_target_tmr.c | 4 +- drivers/target/target_core_device.c | 1 - drivers/target/target_core_sbc.c | 2 +- drivers/target/target_core_tmr.c | 8 +- drivers/target/target_core_transport.c | 130 +- drivers/target/tcm_fc/tfc_cmd.c | 2 - include/target/target_core_base.h | 4 +- include/target/target_core_fabric.h | 2 +- 36 files changed, 4454 insertions(+), 2698 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe target-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html