Assorted fixes + unifying __d_move() and __d_materialise_dentry() + minimal regression fix for d_path() of victims of overwriting rename() ported on top of that. Please, pull from git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git for-linus Shortlog: Al Viro (7): ufs: deal with nfsd/iget races pull rehashing and unlocking the target dentry into __d_materialise_dentry() don't open-code d_rehash() in d_materialise_unique() __d_move(): fold manipulations with ->d_child/->d_subdirs __d_materialise_dentry(): flip the order of arguments kill __d_materialise_dentry() fold unlocking the children into dentry_unlock_parents_for_move() Linus Torvalds (1): fold swapping ->d_name.hash into switch_names() Mikhail Efremov (1): vfs: Don't exchange "short" filenames unconditionally. Miklos Szeredi (2): shmem: fix nlink for rename overwrite directory fuse: honour max_read and max_write in direct_io mode Diffstat: fs/dcache.c | 112 +++++++++++++++++---------------------------------- fs/direct-io.c | 2 +- fs/fuse/file.c | 1 + fs/ufs/ialloc.c | 6 ++- fs/ufs/namei.c | 4 ++ include/linux/uio.h | 2 +- mm/iov_iter.c | 14 ++++--- mm/shmem.c | 4 +- 8 files changed, 60 insertions(+), 85 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe stable" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html