Re: Agent crashes on Alpine Linux guest due to lack of /dev/uinput

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Sorry the delay, I've been away :)

On Sun, Nov 06, 2022 at 07:02:12AM +0000, let-me-use-copy-and-paste wrote:
> I installed Alpine Linux 3.16 virtual machine edition on
> QEMU/KVM using Virt-Manager. I installed XFCE on it. I wanted
> to enable copy-and-paste, so I tried to install spice-vdagent
> on it, but it kept crashing. I checked the output using the
> "-x" parameter, and basically, it crashed due to the lack of
> /dev/uinput. The screenshot is
> at
> I do not know Linux much, so I am not sure if /dev/uinput is
> not present due to the settings of the virtual machine or
> because I have not installed something on Alpine Linux. I tried
> the standard edition of Alpine, and right after the
> installation, /dev/uinput was not present.
> In case that Alpine Linux indeed does not support /dev/uinput,
> can't the spice service run anyway? All I want is text
> copy-and-paste between the host and the guest, and does that
> feature need /dev/uinput?

Well, seems that they do build uinput.ko

It might be a matter of installing the right package and/or
modprobe uinput


Attachment: signature.asc
Description: PGP signature

[Index of Archives]     [Linux Virtualization]     [Linux Virtualization]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]     [Monitors]