Re: Agent crashes on Alpine Linux guest due to lack of /dev/uinput

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Il giorno dom 6 nov 2022 alle ore 08:10 let-me-use-copy-and-paste
<let-me-use-copy-and-paste@xxxxxxxxx> ha scritto:
> I installed Alpine Linux 3.16 virtual machine edition on QEMU/KVM using Virt-Manager. I installed XFCE on it. I wanted to enable copy-and-paste, so I tried to install spice-vdagent on it, but it kept crashing. I checked the output using the "-x" parameter, and basically, it crashed due to the lack of /dev/uinput. The screenshot is at
> I do not know Linux much, so I am not sure if /dev/uinput is not present due to the settings of the virtual machine or because I have not installed something on Alpine Linux. I tried the standard edition of Alpine, and right after the installation, /dev/uinput was not present.
> In case that Alpine Linux indeed does not support /dev/uinput, can't the spice service run anyway? All I want is text copy-and-paste between the host and the guest, and does that feature need /dev/uinput?

   try to add "-f -u /dev/null" to the parameters (that is
"--fake-uinput --uinput-device /dev/null").


[Index of Archives]     [Linux Virtualization]     [Linux Virtualization]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]     [Monitors]