> > On Wed, Nov 23, 2016 at 06:07:18PM +0000, Frediano Ziglio wrote: > > SndChannel -> SndChannelClient > > SndWorker -> SndChannel > > I'd expect an explanation as to why what was called a SndChannel so far > really is a SndChannelClient (as it's going to inherit from > RedChannelClient in the future). Ditto for SndWorker->SndChannel > For the explanation I don't really know. I can imagine that as only one client is supported and channel/client objects are not used the usage of "SndChannel" make sense implementing client/server code. For SndWorker I think Worker is quite a generic term for "code that does something specific", in this case code that deal with sound. >From history this names came from the first commit in git so not much explanation. However I can see struct SndWorker { Channel base; VDInterface *interface; SndChannel *connection; SndWorker *next; }; so I can assume that the SndWorker was always though as a RedChannel (Channel in this commit is the current RedChannel). What about (suggestions welcome): "SndWorker was always based on RedChannel (formerly Channel) while SndChannel always deals with client so moving to current naming it's less coherent to rename SndChannel to SndChannelClient and SndWorker to SndChannel." > I'm wondering if things would be easier to follow if this was split > differently, ie one commit doing SndChannel->SndChannelClient and > renaming of 'channel' variables to 'client' and another commit doing > SndWorker->SndChannel + variable renaming. > > Christophe > I'll try to split, at the end are a series of renames. However taking into account the above commit message I don't know where should fit. OT: was wondering why nobody acked 1/18, is fairly simple. Frediano _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/spice-devel