These objects were used by the sound channel as this channel read/write to/from client directly. This make the code of this channel quite different from the other ones. Also this reduce code duplication from RedChannelClient and increase encapsulation. First set of patches attempt to rename fields/structures to prepare for the conversion to RedChannel/RedChannelClient and GObject. Than other patches basically do the conversion and some cleanup. Frediano Ziglio (18): Remove unused fields sound: Unify commands sound: Use worker directly sound: Rename some objects sound: Rename workers to snd_channels sound: Rename {Record,Playback}Channel to *ChannelClient sound: Rename channel to client if variable used for clients sound: Rename worker to channel sound: Convert SndChannel to GObject sound: Implements config_socket RedChannel callback sound: Convert SndChannelClient to GObject sound: Implement on_disconnect RedChannel callback Remove DummyChannel* objects sound: Reduce message buffer Make RedChannelClient::incoming private sound: Free more on SndChannel finalize sound: Use default disconnect for client channels sound: Reuse code for snd_set_{playback,record}_peer server/Makefile.am | 4 - server/dummy-channel-client.c | 138 --- server/dummy-channel-client.h | 64 -- server/dummy-channel.c | 94 -- server/dummy-channel.h | 60 -- server/red-channel-client-private.h | 11 + server/red-channel-client.c | 12 +- server/red-channel-client.h | 13 - server/sound.c | 1731 +++++++++++++++++------------------ 9 files changed, 866 insertions(+), 1261 deletions(-) delete mode 100644 server/dummy-channel-client.c delete mode 100644 server/dummy-channel-client.h delete mode 100644 server/dummy-channel.c delete mode 100644 server/dummy-channel.h -- 2.7.4 _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/spice-devel