On Sun, Dec 2, 2012 at 12:35 PM, Hans de Goede <hdegoede@xxxxxxxxxx> wrote:
Yeah, but as a first step I would prefer to keep just that mechanical patch, and do further clean-up later on.
Sounds like a nice cleanup to me. Or maybe further
split the recv_ functions into a recv_ and send_next_bit
parts and then have a channel_handle_link()
calling all the send_ and recv_ parts? I think that might
Yeah, but as a first step I would prefer to keep just that mechanical patch, and do further clean-up later on.
end up more readable then a single large function and
the compiler should inline it all anyways (since it is all
called from only 1 place).
I don't think the readibility and modularity will change that much if it's a single function or multiple recv and send functions. Those functions are not reused and the process can't be more linear. Having a single function make it easier to share variables/state (no need to pass values/state). But anyway, that should be a different patch that we will discuss.
--
Marc-André Lureau
_______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/spice-devel