Re: [Redhat-s390-list] OSA/OSA-E Drivers in Red Hat Linux/390

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, Aug 28, 2001 at 10:28:15AM -0500, wrote:
> I appreciate your desire to fight the good fight. But some of us short 
> sighted (and over worked) folks just want to get the thing to work.
> BTW, I forget what I have been paying for my currently non-functioning 
> OSA-Express 100Mbit cards, but I just got a reseller's quote for $8K - so 
> they don't come cheap.
> I look forward to the update with instructions on how to load the OCO 
> drivers. I tried to mount my Marist volume with the sucessfully loading 
> lcs.o so I could copy it over to my RedHat ramdisk installer system, but 
> my ignorance prevents me.
> So ....
> 1) It is very nice that instructions are coming. If it is a matter of 
> days, I will be happy to wait. It would be even nicer to have a quick 
> sketch of how to do this sent to the list so I could make the attempt 

Ok, here is a short description how to add the OC modules to our installer.

- mount the initrd.img it over loopback:

  mkdir initrd
  mount -t ext2 -o loop initrd.img initrd

copy the OCO modules in the lib directory of the initrd:

  cp lcs*o qdio.o qeth.o initrd/lib   # Make sure that you copy the 
                                      # 2.4.5 OCO modules !

umount the loppback initrd:

  umount initrd

> 2) It would have been optimal to include these instructions WHEN the 
> modules were yanked (customer focus).
> 3) If anyone wants to explain to me why I can't mount my Marist volume, I 
> would be grateful:
> insmod dasd_mod dasd=63a-63d

you need to load the dasd_eckd_mod module as well.

  insmod dasd_eckd_mod


 Karsten Hopp        | Mail:
 Red Hat Deutschland | Tel: +49-711-96437-0
 Hauptstaetterstr.58 | Fax: +49-711-96437-111
 D-70178 Stuttgart   | 

[Index of Archives]     [Fedora General Discussion]     [LKML]     [Red Hat Install]     [Red Hat Watch]     [Red Hat Development]     [Linux s390]     [Gimp]     [Yosemite News]

  Powered by Linux