Re: Upgrading to newer RPM

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On Thu, 2015-03-19 at 20:59 +0000, Daugherty, Briac wrote:
> While trying to install an rpm file on a newly created virtual machine, I receive this---
> rpm -ivh rest-api-7.1.0-370.sles11_64.x86_64.rpm
> error: Failed dependencies:
>         rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by rest-api-7.1.0-370.noarch
> After some searching, I realized that the RPM version on this machine
> is too old for the package and I need to upgrade. I downloaded and
> extracted the 4.12 files and FTPed them to this machine. However, I am
> unsure at this point how to actually install this new version.
> Thank you for your time,

Updating RPM to something else than your distributors ships is almost
guaranteed to break something.

You're very likely are attempting to install a package that is for some
other distribution. Find a package for your distributio nor find the
source package (.src.rpm) for the binary package you're attempting to
install and rebuild it.

> Briac Daugherty
> Systems Analyst in IT Infrastructure
> Eastman Chemical Company


Rpm-list mailing list

[Index of Archives]     [RPM Ecosystem]     [Linux Kernel]     [Red Hat Install]     [PAM]     [Red Hat Watch]     [Red Hat Development]     [Red Hat]     [Gimp]     [Yosemite News]     [IETF Discussion]

  Powered by Linux