Onboard Sound ASUS A7V8X-X

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


Hi everybody.

I'm a Linux newbie - just bought my first computer last week.
I have installed RedHat 8.0 (psyche)

I am having trouble setting up the online sound for my ASUSUS a7B8X-X motherboard.

Can you help me?

In the manual that came with the motherboard.
The Audio specifications are: ADI 1980 6-channel CODEC S/PDIF out interface.
Audio controller: AC97 Audio controller

If I start X, then open main => systemsettings => soundcard detection

Then the sound configuration dialog pops up with the following information:

Vendor: VIA technologies
Model: VT8233 AC97 Audio controller
Module: via82cxxx_audio

This seems to be correct information. However clicking on the "Play Test Sound" button has no result.

Within the file /var/log/messages are the following error messages:


localhost insmod: /lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o: init_module: No such device

localhost insmod: Hint: ins_mod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters, you may find more information in syslog or the output from dmesg

localhost ins_mod: /lib/modules/2.4.18-24/kernel/drivers/sound/via82cxxx_audio.o: ins_mod: sound-slot-0 failed

localhost modprove: modprobe: can't locate module sound-service-0-3


It is, indeed, true that the directory /lib/modules/2.4.18-14/kernel/drivers/sound
does not contain a file named via82cxxx_audio.o
It does, however contain a file named ac97_codec.o
and a file named ac97.o

Two solutions immediately suggest themselves:
1. Try using the ac97_codec driver or the ac97 driver instead of the via82cxxx_audio driver
2. Try to download a copy of the via82cxxx_audio driver from the internet.

I tried the first solution first. The original contents of the file /etc/modules.conf was

alias sound-slot-0 via82cxxx_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -s >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -s >/dev/null 2>&1 || :

without really knowing what I was doing, since I'm a complete newbie, I tried changing this to

alias sound-slot-0 ac97
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -s >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -s >/dev/null 2>&1 || :

then rebooting my computer.
The computer successfully rebooted
I then started X and tried again:
main => systemsettings => soundcard detection

Again the sound configuration dialog poped up - but the information was the same as before!

Vendor: VIA technologies
Model: VT8233 AC97 Audio controller
Module: via82cxxx_audio

via82cxxx_audio had not been changed to ac97!!!!

Why is this?
It seems that redhat-config-sound is not making use of the configuration information in /etc/modules.conf
What configuration file is it using instead?
How can I over-ride the auto-probe?
or alternatively, where can I get hold of the via82cxxx_audio driver?

If you've read this far into my email,
Thankyou for your time.

_________________________________________________________________ Keep track of Singapore stock prices. http://www.msn.com.sg/money/

-- Sound-list mailing list Sound-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/sound-list

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux