Re: [Sound] AC97 codec ready in one computer and not ready in theother.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


El sáb, 05 de 04 de 2003 a las 21:55, Kurian John escribió:
> Hi...I had the same problem but I solved it by
> recompiling my kernel. But before that, I replaced the
> i810 and ac97 source files in the drivers/sound
> directory with the ones from Mandrake 8.1
> distribution. Now its working gr8. I downloaded the
> latest kernel (2.4.20), but even it had the same
> problem and was rectified only after the files were
> replaced.
>      This sounds a bit complicated, but if anyone
> knows a simpler way to solve this problem, please
> enlighten us!

Thanks for your reply. I've downloaded from the last prepatch
for 2.4.21 and tried to compile the modules with it but I get a
compilation error when make reaches i810_audio. I have checked that the
source code for i810_audio has changed from that in 2.4.20 (so I imagine
that its authors are trying to improve its performance but perhaps they
have introduced some mistake also). The compilation error message is:

i810_audio.c: In function `i810_ac97_init':
i810_audio.c:2930: structure has no member named `modem'
i810_audio.c: In function `i810_probe':
i810_audio.c:3262: warning: label `out_chan' defined but not used
make[2]: *** [i810_audio.o] Error 1
make[2]: Saliendo directorio `/usr/src/linux-2.4.20/drivers/sound'
make[1]: *** [_modsubdir_sound] Error 2
make[1]: Saliendo directorio `/usr/src/linux-2.4.20/drivers'
make: *** [_mod_drivers] Error 2

(by the way "saliendo directorio" is "exiting directory" in Spanish)

Where can I find the sources for i810_audio and ac97 modules you are
talking about without downloading the full Mandrake distribution to try
your solution? Perhaps you would be kind enough to send me these two
files as an attachment?

Thanks again

Miguel Quirós Olozábal
Departamento de Química Inorgánica
Universidad de Granada
Teléfono: 958240441

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux