Re: [Sound] please help a newbie, red hat 8 and cs4610

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]<


ok, so I went and just downloaded some gcc rpm's and
installed them and then tried running the alsa thing
again.  Here is what I got now, it doesnt seem right
either, can somebody tell me what I'm doing wrong now?

[root@xxx root]# cd /usr/src/alsa/alsa-driver-*
[root@xxx alsa-driver-0.5.12a]# ./configure
--with-cards=cs46xx --with-sequencer=yes;make;make
loading cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a
cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for ranlib... ranlib
checking for a BSD compatible install...
/usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for linux/fs.h... yes
checking for working const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be
included... yes
checking whether gcc needs -traditional... no
checking for directory with kernel source...
checking for kernel version... 0.0.0
checking for kernel module symbol versions... no
checking for PCI support in kernel... no
checking for SGI/MIPS (HAL2) architecture... no
checking for directory to store kernel modules...
checking for debug level... none
checking for processor type... unknown
checking for SMP... no
checking for ISA PnP driver in kernel... no
checking for ISA PnP support... yes
checking for old kill_fasync... yes
checking for dma_addr_t... yes
checking for MUTEX macros... no
checking for driver version... 0.5.12a
checking for sequencer support... yes
checking for OSS/Free emulation... yes
checking for which soundcards to compile driver for...
Unknown soundcard cs46xx, exiting!

Please, run configure script as first...

make dep
make[1]: Entering directory
make -C utils update-deps
make[2]: Entering directory
Makefile:8: ../Makefile.conf: No such file or
make[2]: *** No rule to make target
`../Makefile.conf'.  Stop.
make[2]: Leaving directory
make[1]: *** [cards.config] Error 2
make[1]: Leaving directory
make: *** [include/sndversions.h] Error 2

oh and by the way...

[root@xxx alsa-driver-0.5.12a]# rpm -q gcc
[root@xxx alsa-driver-0.5.12a]# rpm -q krb5-libs

sheesh, I'm such a newbie!

--- Steven Rubenstein <rubensteintrans@xxxxxxxxxxx>
> What version of gcc do you have installed?  Hint: 
> rpm -q gcc
> you also might want to rpm -q krb5-libs
> Tejas Gandhi wrote:
>  > Ok, so I tried installing GCC through the the
> Add/Remove packages 
> thing, but when I try to add the development tools,
> I get an error 
> stating that krb5-libs is missing.  I thought I had
> this installed, but 
> none the less, I went to the redhat website and
> downloaded the rpm's 
> (1.2.5-6 and 1.2.7).  They both stated that I
> already have 1.2.7 
> installed in my computer, yet the add/remove
> packages keeps saying that 
> I dont have 1.2.5-6 and that its needed to install
> the development 
> tools.  Being that I'm completely new to linux, I
> dont know my way 
> around this.  Is the add/remove packages program
> looking for 1.2.5-6 
> specifically while I have 1.2.7 installed?  Any
> ideas/suggestions?
>  > --- Michael Kuss <kuss@xxxxxxxxxx> wrote:
>  >>Ok, second try, I had to realize that I'm
> subscribed with a different 
> name than the "reply to" generates:
>  >>On Tue, 24 Dec 2002, Tejas Gandhi wrote:
>  >>>this is the error I get just from the
> ./configure command so far
>  >>>
>  >>>[root@xxx root]# cd /usr/src/alsa
>  >>>[root@xxx alsa]# bunzip2 alsa-driver-*
>  >>>[root@xxx alsa]# tar -xf alsa-driver-*
>  >>>[root@xxx alsa]# cd alsa-driver-*
>  >>>[root@xxx alsa-driver-0.5.12a]# ./configure
>  >>>--with-cards=cs46xx --with-sequencer=yes
>  >>>creating cache ./config.cache
>  >>>checking for gcc... no
>  >>>checking for cc... no
>  >>>configure: error: no acceptable cc found in
>  >>
>  >>this tells you that you have no compiler package
> installed.  Install 
> gcc!  You may also have to install some library
> packages. Configure 
> and/or make will tell you what is missing.
>  >>Cheers,
>  >>Michael
> _______________________________________________
> Sound-list mailing list
> Sound-list@xxxxxxxxxx

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

[Index of Archives]     [Sound Cards]     [Kernel]     [Red Hat Install]     [Drives]     [Red Hat Development]     [Video 4 Linux]     [Gimp Users]     [Yosemite Trails]

  Powered by Linux