Hello Jeff Mahoney wrote: > Hi all - > > The following are a series of patches that have been kicking around for a > while. I thought I'd just put them out there to gauge interest and to get > some testing before submitting to -mm. > > There are a few groups: > * Little changes (01,02,09) > - Fixes lockdep warnings in xattr code > - Changes reiserfs_panic() to panic() instead of BUG. > - Includes bitmap is_reusable unconditionally and uses to to catch > corruption. This is light-weight now that the stupid loop is gone. > - Make bitmap used cached first zero bit. > > * Error handling (03-08) > - Reformat error/warning/panic/info/etc messages to be consistent with one > another. > - Makes some warnings informational. Rather than printing the > reiserfs_warning() full preamble to declare that a mount option was > invalid, we use reiserfs_info instead. > - Rework reiserfs_warning to take a unique ID, print the function name, > print the device name. > - Rework reiserfs_panic similarly. > - Add reiserfs_error() to handle metadata errors. > - Use reiserfs_error(). > > * Extended attributes (11-21) > - Simplify internal file lookups/opens > - Eliminate per-super xattr lock > - Make per-inode xattr lock more fine-grained > - Remove i_has_xattr_dir flag > - Remove shared xattr detection (unused) > - Use generic xattr handler infrastructure > - Use O_NOATIME for internal file opens > - Add per-file data=ordered mode and use it for xattrs > - Journal xattrs > - Kill xattr_readdir in favor of a for_each_xattr > - Add atomic addition of selinux attributes during inode creation > > * Cleanups, code readability (22-29) > - Cleanup path functions to reduce redundancy > - Strip trailing whitespace from all reiserfs code > - Rename p_s_sb to sb > - Rename p_s_bh to bh > - Rename p_s_inode to inode > - Rename p_s_tb to tb > - Rename misc p_._ variables > - Rename [cn]_* variables > > * Clean up do_balan.c (30-39) > - Factor out buffer_info initializations > - Turn tb->s[12]num and tb[12]bytes into an array > - Split balance_leaf from the 2500 line beast to more manageable chunks > - Clean up balance_leaf_when_delete > - Clean up comments > > I look forward to comments. good work > The journaled xattr changes in particular need > testing as deadlocks may still lurk in there. > > I've also posted the patch set here: > ftp://ftp.suse.com/pub/people/jeffm/reiserfs/kernel-v2.6/2.6.22-rc3-git1/ > > -Jeff > - To unsubscribe from this list: send the line "unsubscribe reiserfs-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html