Re: [PATCH] raid5 improve too many read errors msg by adding limits

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 15 2019, Song Liu wrote:

> On Mon, Aug 12, 2019 at 4:38 PM Xiao Ni <xni@xxxxxxxxxx> wrote:
>>
>>
>>
>> On 08/12/2019 11:30 PM, Nigel Croxon wrote:
>> > Often limits can be changed by admin. When discussing such things
>> > it helps if you can provide "self-sustained" facts. Also
>> > sometimes the admin thinks he changed a limit, but it did not
>> > take effect for some reason or he changed the wrong thing.
>> >
>> > Signed-off-by: Nigel Croxon <ncroxon@xxxxxxxxxx>
>> > ---
>> >   drivers/md/raid5.c | 4 ++--
>> >   1 file changed, 2 insertions(+), 2 deletions(-)
>> >
>> > diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
>> > index 522398f61eea..e2b58b58018b 100644
>> > --- a/drivers/md/raid5.c
>> > +++ b/drivers/md/raid5.c
>> > @@ -2566,8 +2566,8 @@ static void raid5_end_read_request(struct bio * bi, int error)
>> >                               bdn);
>> >               } else if (atomic_read(&rdev->read_errors)
>> >                        > conf->max_nr_stripes)
>> > -                     pr_warn("md/raid:%s: Too many read errors, failing device %s.\n",
>> > -                            mdname(conf->mddev), bdn);
>> > +                     pr_warn("md/raid:%s: Too many read errors (%d), failing device %s.\n",
>> > +                            mdname(conf->mddev), conf->max_nr_stripes, bdn);
>> >               else
>> >                       retry = 1;
>> >               if (set_bad && test_bit(In_sync, &rdev->flags)
>>
>> Hi Nigel
>>
>> Is it better to print rdev->read_errors too? So it can know the error
>> numbers and the max nr stripes
>
> I think rdev->read_errors is more useful here.
>
> Hi Neil,
>
> I have a question for this case: this patch changes an existing pr_warn() line,
> which in theory, may break user scripts that grep for this line from dmesg.
> How much do we care about these scripts?

I don't think we need to care about this.  Kernel log message aren't
normally considered part of the ABI.
However in this case, it might actually be more readable to have just
add another line:

  md/raid:md0: 513 read_errors, > 512 stripes
  md/raid:md0: Too many read errors, failing device sda1

??

NeilBrown

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux RAID Wiki]     [ATA RAID]     [Linux SCSI Target Infrastructure]     [Linux Block]     [Linux IDE]     [Linux SCSI]     [Linux Hams]     [Device Mapper]     [Device Mapper Cryptographics]     [Kernel]     [Linux Admin]     [Linux Net]     [GFS]     [RPM]     [git]     [Yosemite Forum]


  Powered by Linux