On Mon, May 18, 2009 at 05:59:41PM -0700, Dan Williams wrote: > diff --git a/crypto/async_tx/async_memcpy.c b/crypto/async_tx/async_memcpy.c > index 7117ec6..c9342ae 100644 > --- a/crypto/async_tx/async_memcpy.c > +++ b/crypto/async_tx/async_memcpy.c > @@ -35,26 +35,23 @@ > * @src: src page > * @offset: offset in pages to start transaction > * @len: length in bytes > - * @flags: ASYNC_TX_ACK > - * @depend_tx: memcpy depends on the result of this transaction > - * @cb_fn: function to call when the memcpy completes > - * @cb_param: parameter to pass to the callback routine > + * @submit: submission / completion modifiers > */ > struct dma_async_tx_descriptor * > async_memcpy(struct page *dest, struct page *src, unsigned int dest_offset, > - unsigned int src_offset, size_t len, enum async_tx_flags flags, > - struct dma_async_tx_descriptor *depend_tx, > - dma_async_tx_callback cb_fn, void *cb_param) > + unsigned int src_offset, size_t len, > + struct async_submit_ctl *submit) > { The third parameter is called "dest_offset", but the comment refers to "@offset". > +struct async_submit_ctl { > + enum async_tx_flags flags; > + struct dma_async_tx_descriptor *depend_tx; > + dma_async_tx_callback cb_fn; > + void *cb_param; > + void *scribble; > +}; Can't scribble be of type addr_conv_t *? Apart from these two minor issues the patch looks really nice. Thanks for taking the time to combine the common submission parameters to the new structure. This improves readability of the code and makes adaptation to future needs easier. Signed-off-by: Andre Noll <maan@xxxxxxxxxxxxxxx> Andre -- The only person who always got his work done by Friday was Robinson Crusoe
Attachment:
signature.asc
Description: Digital signature