On Thu, Jun 01, 2006 at 11:22:09AM +1000, Neil Brown wrote:
On Thursday June 1, eyal@xxxxxxxxxxxxxx wrote:
Alex Davis wrote:
>>short swap16(short in)
>>{
>> int i;
>> short out=0;
>> for (i=0; i<4; i++) {
>> out = out<<8 | (in&255);
>> in = in >> 8;
>> }
>> return out;
>>}
>
> Shouldn't that be "for (i=0; i<2; i++) {..." ?
Well, yes... if you want the code to actually work, I guess that might
be an improvement....
most important,
shouldn't that be:
__u16 swap16(__u16 in)
?
Regards,
L.
--
Luca Berra -- bluca@xxxxxxxxxx
Communication Media & Services S.r.l.
/"\
\ / ASCII RIBBON CAMPAIGN
X AGAINST HTML MAIL
/ \
-
To unsubscribe from this list: send the line "unsubscribe linux-raid" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html