>short swap16(short in) >{ > int i; > short out=0; > for (i=0; i<4; i++) { > out = out<<8 | (in&255); > in = in >> 8; > } > return out; >} Shouldn't that be "for (i=0; i<2; i++) {..." ? I code, therefore I am __________________________________________________ Do You Yahoo!? Tired of spam? Yahoo! Mail has the best spam protection around http://mail.yahoo.com - To unsubscribe from this list: send the line "unsubscribe linux-raid" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html