On Sat, 2016-01-23 at 12:31 +1100, Chris Billington wrote: > Renamed all variables pertaining to latency offsets of sinks and sources, > calling them "port_latency_offset" or similar instead. All of these variables > refer to latency offsets inherited from ports, rather than being unique to > the sinks or sources themselves. > > This change is to pave the way for additional functionality for setting > latency offsets on sources and sinks independenly from the value they inherit > from their port. In order to implement them we first need this rename so that > the two latency offsets can be stored individually and summed when reporting > the total latency of the source or sink. > > The renames made are: > > pa_sink_set_latency_offset() -> pa_sink_set_port_latency_offset() > pa_source_set_latency_offset() -> pa_source_set_port_latency_offset() > sink->latency_offset -> sink->port_latency_offset > sink->thread_info.latency_offset -> sink->thread_info.port_latency_offset > source->latency_offset -> source->port_latency_offset > source->thread_info.latency_offset -> source->thread_info.port_latency_offset > PA_SINK_MESSAGE_SET_LATENCY_OFFSET -> PA_SINK_MESSAGE_SET_PORT_LATENCY_OFFSET > PA_SOURCE_MESSAGE_SET_LATENCY_OFFSET -> PA_SOURCE_MESSAGE_SET_PORT_LATENCY_OFFSET > source->thread_info.latency_offset -> source->thread_info.port_latency_offset > --- >  src/pulsecore/device-port.c |  4 ++-- >  src/pulsecore/sink.c        | 28 ++++++++++++++-------------- >  src/pulsecore/sink.h        | 10 +++++----- >  src/pulsecore/source.c      | 28 ++++++++++++++-------------- >  src/pulsecore/source.h      | 10 +++++----- >  5 files changed, 40 insertions(+), 40 deletions(-) Thanks, looks good. Applied to the "next" branch. -- Tanu