On Mon, 2016-02-29 at 15:46 +0530, arun at accosted.net wrote: > Â void* pa_rtpoll_item_get_userdata(pa_rtpoll_item *i) { > Â Â Â Â Â pa_assert(i); > Â > -Â Â Â Â return i->userdata; > +Â Â Â Â return i->work_userdata; > Â } I think it would make sense to rename the function to pa_rtpoll_item_get_work_userdata(). > Â static int asyncmsgq_read_before(pa_rtpoll_item *i) { > Â Â Â Â Â pa_assert(i); > Â > -Â Â Â Â if (pa_asyncmsgq_read_before_poll(i->userdata) < 0) > +Â Â Â Â if (pa_asyncmsgq_read_before_poll(i->work_userdata) < 0) In the asyncmsgq read before and after callbacks you use work_userdata, but in the write before and after callbacks you use before/after_userdata. All of these userdatas are the same, so it doesn't affect the behaviour, but it would be good to be consistent. -- Tanu