[PATCH v4 0/3] int3472: Support GPIO con_id based on _HID

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi folks,

One patch turned into a set, the second patch being the original one.

since v3:

- Add a patch (first one) to switch to unsigned long type for polarity
  field and renames it as gpio_flags.

- Use a polarity_low boolean field for indicating the GPIO polarity. This
  is turned to gpio_flags in int3472_get_con_id_and_polarity().

- Put the new polarity_low bool field next to the u8's for better struct
  packing.

- Add a patch (last one) to rename "func" as "con_id" which is used
  throughout the GPIO framework.

Sakari Ailus (3):
  platform/x86: int3472: Use correct type for "polarity", call it
    gpio_flags
  platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
  platform/x86: int3472: Call "func" "con_id" instead

 drivers/platform/x86/intel/int3472/discrete.c | 98 +++++++++++++------
 1 file changed, 68 insertions(+), 30 deletions(-)

-- 
2.39.5





[Index of Archives]     [Linux Kernel Development]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux