On Wed, May 11, 2022 at 4:16 AM <cgel.zte@xxxxxxxxx> wrote: > > From: Minghao Chi <chi.minghao@xxxxxxxxxx> > > Use kobj_to_dev() instead of open-coding it. Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx> > Signed-off-by: Minghao Chi <chi.minghao@xxxxxxxxxx> > --- > v1->v2: > remove Reported-by: Zeal Robot <zealci@xxxxxxxxxx> > > drivers/platform/x86/toshiba_acpi.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/platform/x86/toshiba_acpi.c > b/drivers/platform/x86/toshiba_acpi.c > index f113dec98e21..0fc9e8b8827b 100644 > --- a/drivers/platform/x86/toshiba_acpi.c > +++ b/drivers/platform/x86/toshiba_acpi.c > @@ -2353,7 +2353,7 @@ static struct attribute *toshiba_attributes[] = { > static umode_t toshiba_sysfs_is_visible(struct kobject *kobj, > struct attribute *attr, int idx) > { > - struct device *dev = container_of(kobj, struct device, kobj); > + struct device *dev = kobj_to_dev(kobj); > struct toshiba_acpi_dev *drv = dev_get_drvdata(dev); > bool exists = true; > > -- > 2.25.1 > > -- With Best Regards, Andy Shevchenko