On Wed, May 11, 2022 at 4:15 AM <cgel.zte@xxxxxxxxx> wrote: > > From: Minghao Chi <chi.minghao@xxxxxxxxxx> > > Use kobj_to_dev() instead of open-coding it. Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx> > Signed-off-by: Minghao Chi <chi.minghao@xxxxxxxxxx> > --- > v1->v2: > remove Reported-by: Zeal Robot <zealci@xxxxxxxxxx> I believe you want to give credit to the bot in the future patches like this. You may use commit message to add something like "The suggestion has been given by Zeal Robot." > drivers/platform/x86/samsung-laptop.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/platform/x86/samsung-laptop.c b/drivers/platform/x86/samsung-laptop.c > index 19f6b456234f..c187dcdf82f0 100644 > --- a/drivers/platform/x86/samsung-laptop.c > +++ b/drivers/platform/x86/samsung-laptop.c > @@ -1208,7 +1208,7 @@ static int __init samsung_backlight_init(struct samsung_laptop *samsung) > static umode_t samsung_sysfs_is_visible(struct kobject *kobj, > struct attribute *attr, int idx) > { > - struct device *dev = container_of(kobj, struct device, kobj); > + struct device *dev = kobj_to_dev(kobj); > struct samsung_laptop *samsung = dev_get_drvdata(dev); > bool ok = true; > > -- > 2.25.1 > > -- With Best Regards, Andy Shevchenko