On 8/25/21 5:06 PM, Thomas Weißschuh wrote:
On Mi, 2021-08-25T11:47-0500, Daniel Dadap wrote:
+static const struct wmi_device_id wmaa_backlight_wmi_id_table[] = {
+ { .guid_string = WMAA_WMI_GUID },
+ { },
+MODULE_ALIAS("wmi:"WMAA_WMI_GUID);
Can you move this closer to GUID? But I'm not sure what is the
preferred style. Hans?
I'll do whatever is most stylistically preferred.
This could also be expressed as, which is presumably the nicer way:
MODULE_DEVICE_TABLE(wmi, wmaa_backlight_wmi_id_table);
Okay, thanks. In the meantime I've moved the declaration of this table
and the #define for the WMAA_WMI_GUID macro down to the end of the file,
right before the pile of MODULE_* macros where we also use WMAA_WMI_GUID
for the modalias, but if there's a more preferred style here just let me
know.