On Tue, Aug 6, 2019 at 3:23 AM Kristian Klausen <kristian@xxxxxxxxxx> wrote: > > Most newer ASUS laptops supports limiting the battery charge level, which > help prolonging the battery life. > > Tested on a Zenbook UX430UNR. > > Signed-off-by: Kristian Klausen <kristian@xxxxxxxxxx> > --- > I'm not sure what to call it, is charge threshold good enough or do you > have any better ideas? The spec calls it "Maximum Charging Percentage". I think something along those lines would be clearer. It would be good to have a one line explanatory comment against where you introduce the variable, so that it's clear from glancing at the code (not just the commit message) what this functionality actually is. Also you need a Documentation/ entry for this new file where you can describe it a little more verbosely. The 0x00120057 device is officially called "Relative state of charge", not sure if you want to somehow follow a similar naming scheme there, I don't have a real preference. > /* Misc */ > #define ASUS_WMI_DEVID_CAMERA 0x00060013 > +#define ASUS_WMI_CHARGE_THRESHOLD 0x00120057 Please keep the devices ordered numerically by their ID Thanks Daniel