On 06/08/2018 10:09 AM, Jarkko Sakkinen wrote: > + ret = sgx_edbgrd(encl, entry, align, data); > + if (ret) > + break; > + if (write) { > + memcpy(data + offset, buf + i, cnt); > + ret = sgx_edbgwr(encl, entry, align, data); > + if (ret) > + break; > + } > + else > + memcpy(buf + i,data + offset, cnt); > + } The SGX instructions like "edbgrd" be great to put on a license plat, but we can do better in the kernel. Can you give these reasonable english names, please? sgx_debug_write(), maybe? Note that we have plenty of incomprehensible instruction names in the kernel like "wrpkru", but we do our best to keep them as confined as possible and make sure they don't hurt code readability.