[snip] > preg_match("/false/i", $string) ? false : true; ,---- | $foo = (strcmp('true', $string) == 0); `---- works as well :) I don't like those kinds of things for this purpose because it takes longer for people new to the code to read and understand it than, say ,---- | (boolean) $string; `---- (which in my case does a pretty meaningless conversion) [/snip] If you are worried that it takes longer for people new to the code to read and understand then add comments! If it is about readability then give them something to read. You could even create a function that is more readable than the 'if' alone; $foo = booleanString($string); -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php