Re: postgis Error during upgrade

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear, I think that in this case the only feasible way is to jump from pg9.6 to pg10 and from there jump from pg10 to pg14


Erik R. Serrano Saavedra
Ingeniero de Sistemas Informáticos
      Data Base Administrator

El mar, 25 jul 2023 a las 15:12, Roland Che (<rolandngwa31@xxxxxxxxx>) escribió:
Thanks everyone for @Erik yes dumping the data and restore on the
target will work but we have like 900 servers , like 5 thousand
databases and we use ansible for all deployments so to do dump and
restore will be cumbersome that is the reason we are looking into

On Tue, Jul 25, 2023 at 1:58 PM Erik Serrano <eserranos@xxxxxxxxx> wrote:
> Dear,
> Very old versions will never have the new features that current applications have, which will always fail when you want to migrate, so I advise you... look, there is an official postgresql page where you can see the compatibility between versions and after that, mount the PG14 version on a destination server and only export the schemas, users and data.
> Then you check your applications and if everything goes well, that's it... or you can do a POC with what I'm telling you before doing it in a productive environment
> I hope it works for you, regards
> Erik R. Serrano Saavedra
> Ingeniero de Sistemas Informáticos
>       Data Base Administrator
>         eserranos@xxxxxxxxx
>                  998596691
> El vie, 21 jul 2023 a las 4:23, Ilya Kosmodemiansky (<ik@xxxxxxxxxxxxx>) escribió:
>> Hi Roland,
>> On Fri, Jul 21, 2023 at 9:39 AM Roland Che <rolandngwa31@xxxxxxxxx> wrote:
>> >
>> > Hello all
>> > i am trying to upgrade from postgres 9.6 to the latest minor version of 14.
>> Upgrading Postgres from such an old version with postgis is a bit
>> tricky. In order to upgrade to Postgres version 13 you need to upgrade
>> postgis extension to version 3.0, otherwise your postgis would be
>> broken, and you would need to transfer data logically which is not a
>> nice experience.
>> for Postgis 3.0 PostgreSQL 9.5 or higher is required, so you can
>> upgrade Postgis according to documentation and then do a Postgres
>> upgrade.
>> Best regards,
>> Ilya
>> > And we have a couple of extensions inclusing postgis .
>> > We have postgis 2.3 as seen below:
>> >
>> >

[Index of Archives]     [Postgresql Home]     [Postgresql General]     [Postgresql Performance]     [Postgresql PHP]     [Postgresql Jobs]     [PHP Users]     [PHP Databases]     [PHP Home]     [PHP on Windows]     [Kernel Newbies]     [PHP Classes]     [PHP Databases]     [Yosemite Forum]

  Powered by Linux