Cypher data blank or corrupted when encrypted using openssl 3.0.7

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




I recently upgraded openssl 1.1.1s to openssl 3..0.7. I am facing issue with encryption and decryption of video clip after upgrade to 3.0.7. With openssl 1.1.1s the application work perfectly with encryption and decryption. I am using EVP_EncryptInit_ex(), EVP_EncryptUpdate(), EVP_EncryptFinal() for encryption and EVP_DecryptInit_ex(), EVP_DecryptUpdate(), EVP_DecryptFinal() for decryption. Other than this I am using HMAC apis in code which is acceptable in 3.0.7.


I have tried following ways:

1) Tried replacing deprecated HMAC apis 

2) Tried adding padding using EVP_CIPHER_CTX_set_padding() on decryption 

3) Tried adding key pair on encryption and decryption 

4) Tried setting key length using EVP_CIPHER_CTX_set_key_length() 

6) Tried adding FIPS values in code


Nothing work out.


As per my observation, cipher data coming blank or corrupted when try to decrypt video clip.


Please let me know what change I need to make in code when upgrade from openssl 1.1.1s to openssl 3.0.7 to make encryption and decryption work correctly.


Thanks & Regards


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux