Phil Sutter <phil@xxxxxx> wrote: > +static void notargets_hlist_insert(const char *name) > +{ > + struct notarget *cur; > + > + if (!name) > + return; > + > + cur = xtables_malloc(sizeof(*cur) + strlen(name) + 1); > + cur->name[0] = '\0'; > + strcat(cur->name, name); strcpy seems more readable than strcat here. Other than that this looks good to me.