Hi, [ Compile tested-only and userspace update is missing ] This patchset adds NFT_CT_HELPER_OBJNAME to match on the helper object name, ie. >From nftables, existing (inconsistent) syntax can be left in place for backward compatibility. The new proposed syntax would more explicitly refer to match the user wants to do, e.g. ct helper name set "ftp-21" ct helper name "ftp-21" For NFT_CT_HELPER_TYPE (formerly NFT_CT_HELPER), syntax would be: ct helper type "ftp" It should be also possible to support for: ct helper type set "ftp" via implicit object, this infrastructure is missing in the kernel though, the idea would be to create an implicit object that is attached to the rule. Such object would be released when the rule is removed. Let me know. Pablo Neira Ayuso (2): netfilter: nftables: rename NFT_CT_HELPER to NFT_CT_HELPER_TYPE netfilter: nftables: add NFT_CT_HELPER_OBJNAME include/net/netfilter/nf_conntrack_helper.h | 1 + include/uapi/linux/netfilter/nf_tables.h | 7 +++-- net/netfilter/nf_conntrack_helper.c | 1 + net/netfilter/nft_ct.c | 30 +++++++++++++++++---- 4 files changed, 32 insertions(+), 7 deletions(-) -- 2.20.1