Re: [PATCH libnetfilter_queue 1/1] src: add pktb_alloc2() and pktb_head_size()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Pablo,

On Sun, May 10, 2020 at 05:10:01PM +0200, Pablo Neira Ayuso wrote:
> On Sun, May 10, 2020 at 11:53:17PM +1000, Duncan Roe wrote:
> > pktb_alloc2() avoids the malloc/free overhead in pktb_alloc() and also
> > eliminates memcpy() of the payload except when mangling increases the
> > packet length.
> >
> >  - pktb_mangle() does the memcpy() if need be.
> >    Packet metadata is altered in this case
> >  - All the _mangle functions are altered to account for possible change tp
> >    packet metadata
> >  - Documentation is updated
>
> Many chunks of this patchset look very much the same I posted. I'll
> apply my patchset and please rebase any update on top of it.
>
> Thanks.

Apologies for the colourful language in the previous post. I could see
something was very wrong but was too tired to formulate a reasoned response.

My concern is with the calling sequence of pktb_setup().
There's a detailed explanation in one of the patch reviews I just posted.
As long as you're happy with that bit, commit what you like.
If it would save you time, the following patch applied on top of my initial
patch aligns with what you posted, after making the corrections in my reviews.
You might like to try them and see what you think.
Or, just apply yours and I'll rebase. But that *will* include changing the
calling sequence of pktb_setup().

Cheers ... Duncan.

Duncan Roe (1):
  src & doc: Rename pktb_alloc2 to pktb_setup

 fixmanpages.sh                       |  2 +-
 include/libnetfilter_queue/pktbuff.h |  4 +++-
 src/extra/pktbuff.c                  | 37 ++++++++++++++++++------------------
 src/nlmsg.c                          |  2 +-
 4 files changed, 23 insertions(+), 22 deletions(-)

--
2.14.5




[Index of Archives]     [Netfitler Users]     [Berkeley Packet Filter]     [LARTC]     [Bugtraq]     [Yosemite Forum]

  Powered by Linux