Hello, On Thursday, 2008 July 24 at 9:10:59 +0200, Pablo Neira Ayuso wrote: > Eric Leblond wrote: > > This patch adds a module named RAWMAC which is in charge of parsing the > > hardware header to extract source and destination hardware address. > > I think that this should be merged with MAC2STR, can you see any other > potential user of this information apart from the string converter? No, this was also my conclusion before falling asleep yesterday ;) > Also, it would be nice to rename it to HW2STR instead. Ok. > Minor glitch below: > > > +static int parse_rawmac(struct ulogd_key *ret, struct ulogd_key *inp, int type) > > +{ > > + switch (type) { > > + case ARPHRD_ETHER: > > + return parse_ethernet(ret, inp); > > + default: > > + ulogd_log(ULOGD_NOTICE, "Unsupported hardware type (%d), " > > + "unable to parse.\n", GET_VALUE(ret, KEY_RAW_TYPE).ui16); > > This can generate lots of log messages. I prefer to remove this and > document that only ethernet is supported at the moment. Ok, good idea. BR, -- Eric Leblond INL: http://www.inl.fr/ NuFW: http://www.nufw.org/ -- To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html