The quilt patch titled Subject: mm: kmsan: use helper macros PAGE_ALIGN and PAGE_ALIGN_DOWN has been removed from the -mm tree. Its filename was mm-kmsan-use-helper-macros-page_align-and-page_align_down.patch This patch was dropped because it was merged into the mm-stable branch of git://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm ------------------------------------------------------ From: ZhangPeng <zhangpeng362@xxxxxxxxxx> Subject: mm: kmsan: use helper macros PAGE_ALIGN and PAGE_ALIGN_DOWN Date: Thu, 27 Jul 2023 09:16:12 +0800 Use helper macros PAGE_ALIGN and PAGE_ALIGN_DOWN to improve code readability. No functional modification involved. Link: https://lkml.kernel.org/r/20230727011612.2721843-4-zhangpeng362@xxxxxxxxxx Signed-off-by: ZhangPeng <zhangpeng362@xxxxxxxxxx> Reviewed-by: Alexander Potapenko <glider@xxxxxxxxxx> Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx> Cc: Kefeng Wang <wangkefeng.wang@xxxxxxxxxx> Cc: Marco Elver <elver@xxxxxxxxxx> Cc: Nanyong Sun <sunnanyong@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/kmsan/shadow.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) --- a/mm/kmsan/shadow.c~mm-kmsan-use-helper-macros-page_align-and-page_align_down +++ a/mm/kmsan/shadow.c @@ -281,8 +281,8 @@ void __init kmsan_init_alloc_meta_for_ra struct page *page; u64 size; - start = (void *)ALIGN_DOWN((u64)start, PAGE_SIZE); - size = ALIGN((u64)end - (u64)start, PAGE_SIZE); + start = (void *)PAGE_ALIGN_DOWN((u64)start); + size = PAGE_ALIGN((u64)end - (u64)start); shadow = memblock_alloc(size, PAGE_SIZE); origin = memblock_alloc(size, PAGE_SIZE); for (u64 addr = 0; addr < size; addr += PAGE_SIZE) { _ Patches currently in -mm which might be from zhangpeng362@xxxxxxxxxx are