Most of the rest of MM and just about all of the rest of everything else. Subsystems affected by this patch series: mm:hotfixes mm:memcg mm:vmscan mm:z3fold mm:cma mm:nommu procfs misc get_maintainer lib checkpatch binfmt init kprobes codafs hfs ufs reiserfs ptrace signals rapidio pids pps kgdb bug ipc mm:lz4 mm:dax mm:pagemap mm:cleanups cleanups 100 patches, based on 50950626414a982c8ed539128c7f69a3d328a970: Subsystem: mm:hotfixes Vitaly Wool <vitalywool@xxxxxxxxx>: mm/z3fold: don't try to use buddy slots after free Arnd Bergmann <arnd@xxxxxxxx>: mm/shmem.c: fix unused shmem_parse_huge() function warning lib/mpi/longlong.h: fix building with 32-bit x86 mm/slab_common.c: work around clang bug #42570 Ryohei Suzuki <ryh.szk.cmnty@xxxxxxxxx>: mm/cma.c: fix a typo ("alloc_cma" -> "cma_alloc") in cma_release() comments Henry Burns <henryburns@xxxxxxxxxx>: mm/z3fold.c: allow __GFP_HIGHMEM in z3fold_alloc Subsystem: mm:memcg Yafang Shao <laoar.shao@xxxxxxxxx>: mm/memcontrol.c: keep local VM counters in sync with the hierarchical ones Subsystem: mm:vmscan Yafang Shao <laoar.shao@xxxxxxxxx>: Patch series "mm/vmscan: calculate reclaimed slab in all reclaim paths": mm/vmscan.c: add a new member reclaim_state in struct shrink_control mm/vmscan.c: calculate reclaimed slab caches in all reclaim paths Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>: mm/vmscan.c: add checks for incorrect handling of current->reclaim_state Subsystem: mm:z3fold Henry Burns <henryburns@xxxxxxxxxx>: mm/z3fold.c: remove z3fold_migration trylock mm/z3fold.c: reinitialize zhdr structs after migration Subsystem: mm:cma Doug Berger <opendmb@xxxxxxxxx>: mm/cma.c: fail if fixed declaration can't be honored Subsystem: mm:nommu Christoph Hellwig <hch@xxxxxx>: mm: fix the MAP_UNINITIALIZED flag mm: provide a print_vma_addr stub for !CONFIG_MMU mm: stub out all of swapops.h for !CONFIG_MMU Subsystem: procfs Alexey Dobriyan <adobriyan@xxxxxxxxx>: tools/testing/selftests/proc/proc-pid-vm.c: hide "segfault at ffffffffff600000" dmesg spam Kairui Song <kasong@xxxxxxxxxx>: vmcore: add a kernel parameter novmcoredd Alexey Dobriyan <adobriyan@xxxxxxxxx>: include/linux/kernel.h: add typeof_member() macro fs/proc/inode.c: use typeof_member() macro proc: test /proc/sysvipc vs setns(CLONE_NEWIPC) Radoslaw Burny <rburny@xxxxxxxxxx>: fs/proc/proc_sysctl.c: fix the default values of i_uid/i_gid on /proc/sys inodes. Subsystem: misc Weitao Hou <houweitaoo@xxxxxxxxx>: kernel: fix typos and some coding style in comments Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx>: linux/bits.h: make BIT(), GENMASK(), and friends available in assembly arch: replace _BITUL() in kernel-space headers with BIT() Stephen Kitt <steve@xxxxxxx>: arch/*: remove unused isa_page_to_bus() Qian Cai <cai@xxxxxx>: asm-generic: fix a compilation warning Subsystem: get_maintainer Joe Perches <joe@xxxxxxxxxxx>: get_maintainer: add ability to skip moderated mailing lists Subsystem: lib Alexey Dobriyan <adobriyan@xxxxxxxxx>: lib/list: tweak LIST_POISON2 for better code generation on x86_64 Peter Rosin <peda@xxxxxxxxxx>: Patch series "lib/string: search for NUL with strchr/strnchr": lib/string.c: allow searching for NUL with strnchr lib/test_string.c: avoid masking memset16/32/64 failures lib/test_string.c: add some testcases for strchr and strnchr Kees Cook <keescook@xxxxxxxxxxxx>: lib/test_overflow.c: avoid tainting the kernel and fix wrap size Alexander Potapenko <glider@xxxxxxxxxx>: lib: introduce test_meminit module Anshuman Khandual <anshuman.khandual@xxxxxxx>: mm/ioremap: check virtual address alignment while creating huge mappings mm/ioremap: probe platform for p4d huge map support Jonathan Corbet <corbet@xxxxxxx>: lib/string_helpers: fix some kerneldoc warnings Arnd Bergmann <arnd@xxxxxxxx>: lib/test_meminit.c: fix -Wmaybe-uninitialized false positive Alexander Potapenko <glider@xxxxxxxxxx>: lib/test_meminit.c: minor test fixes Michel Lespinasse <walken@xxxxxxxxxx>: lib/rbtree: avoid generating code twice for the cached versions Subsystem: checkpatch Matteo Croce <mcroce@xxxxxxxxxx>: checkpatch.pl: warn on duplicate sysctl local variable Subsystem: binfmt YueHaibing <yuehaibing@xxxxxxxxxx>: fs/binfmt_flat.c: remove set but not used variable 'inode' Alexey Dobriyan <adobriyan@xxxxxxxxx>: fs/binfmt_elf.c: delete stale comment Subsystem: init Kees Cook <keescook@xxxxxxxxxxxx>: init/Kconfig: fix neighboring typos Subsystem: kprobes Anshuman Khandual <anshuman.khandual@xxxxxxx>: mm, kprobes: generalize and rename notify_page_fault() as kprobe_page_fault() Subsystem: codafs Jan Harkes <jaharkes@xxxxxxxxxx>: Patch series "Coda updates": coda: pass the host file in vma->vm_file on mmap Mikko Rapeli <mikko.rapeli@xxxxxx>: uapi linux/coda.h: use __kernel_pid_t for userspace uapi linux/coda_psdev.h: move upc_req definition from uapi to kernel side headers Zhouyang Jia <jiazhouyang09@xxxxxxxxx>: coda: add error handling for fget Jan Harkes <jaharkes@xxxxxxxxxx>: coda: potential buffer overflow in coda_psdev_write() Sam Protsenko <semen.protsenko@xxxxxxxxxx>: coda: fix build using bare-metal toolchain Jan Harkes <jaharkes@xxxxxxxxxx>: coda: don't try to print names that were considered too long uapi linux/coda_psdev.h: move CODA_REQ_ from uapi to kernel side headers Colin Ian King <colin.king@xxxxxxxxxxxxx>: coda: clean up indentation, replace spaces with tab Arnd Bergmann <arnd@xxxxxxxx>: coda: stop using 'struct timespec' in user API Jan Harkes <jaharkes@xxxxxxxxxx>: coda: change Coda's user api to use 64-bit time_t in timespec Dan Carpenter <dan.carpenter@xxxxxxxxxx>: coda: get rid of CODA_ALLOC() coda: get rid of CODA_FREE() Jan Harkes <jaharkes@xxxxxxxxxx>: coda: bump module version David Howells <dhowells@xxxxxxxxxx>: coda: move internal defs out of include/linux/ [ver #2] Jan Harkes <jaharkes@xxxxxxxxxx>: coda: remove uapi/linux/coda_psdev.h Fabian Frederick <fabf@xxxxxxxxx>: coda: destroy mutex in put_super() coda: use SIZE() for stat coda: add __init to init_coda_psdev() coda: remove sysctl object from module when unused coda: remove sb test in coda_fid_to_inode() coda: ftoc validity check integration Pedro Cuadra <pjcuadra@xxxxxxxxx>: coda: add hinting support for partial file caching Subsystem: hfs Mathieu Malaterre <malat@xxxxxxxxxx>: fs/hfsplus/xattr.c: replace strncpy with memcpy Subsystem: ufs YueHaibing <yuehaibing@xxxxxxxxxx>: fs/ufs/super.c: remove set but not used variable 'usb3' Subsystem: reiserfs Hariprasad Kelam <hariprasad.kelam@xxxxxxxxx>: fs/reiserfs/journal.c: change return type of dirty_one_transaction Subsystem: ptrace "Dmitry V. Levin" <ldv@xxxxxxxxxxxx>: nds32: fix asm/syscall.h hexagon: define syscall_get_error() and syscall_get_return_value() mips: define syscall_get_error() parisc: define syscall_get_error() powerpc: define syscall_get_error() Elvira Khabirova <lineprinter@xxxxxxxxxxxx>: ptrace: add PTRACE_GET_SYSCALL_INFO request "Dmitry V. Levin" <ldv@xxxxxxxxxxxx>: selftests/ptrace: add a test case for PTRACE_GET_SYSCALL_INFO Subsystem: signals Alexey Dobriyan <adobriyan@xxxxxxxxx>: signal: reorder struct sighand_struct Oleg Nesterov <oleg@xxxxxxxxxx>: signal: simplify set_user_sigmask/restore_user_sigmask select: change do_poll() to return -ERESTARTNOHAND rather than -EINTR select: shift restore_saved_sigmask_unless() into poll_select_copy_remaining() Subsystem: rapidio Dan Carpenter <dan.carpenter@xxxxxxxxxx>: drivers/rapidio/devices/rio_mport_cdev.c: NUL terminate some strings Subsystem: pids "Joel Fernandes (Google)" <joel@xxxxxxxxxxxxxxxxx>: kernel/pid.c: convert struct pid count to refcount_t Subsystem: pps Miroslav Lichvar <mlichvar@xxxxxxxxxx>: drivers/pps/pps.c: clear offset flags in PPS_SETPARAMS ioctl Subsystem: kgdb Leonard Crestez <leonard.crestez@xxxxxxx>: scripts/gdb: add lx-genpd-summary command scripts/gdb: add helpers to find and list devices Subsystem: bug Drew Davenport <ddavenport@xxxxxxxxxxxx>: include/asm-generic/bug.h: fix "cut here" for WARN_ON for __WARN_TAINT architectures Subsystem: ipc Kees Cook <keescook@xxxxxxxxxxxx>: ipc/mqueue.c: only perform resource calculation if user valid Subsystem: mm:lz4 Tom Levy <tomlevy93@xxxxxxxxx>: include/linux/lz4.h: fix spelling and copy-paste errors in documentation Subsystem: mm:dax Pavel Tatashin <pasha.tatashin@xxxxxxxxxx>: Patch series ""Hotremove" persistent memory", v6: device-dax: fix memory and resource leak if hotplug fails mm/hotplug: make remove_memory() interface usable device-dax: "Hotremove" persistent memory that is used like normal RAM "Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxxxxxx>: mm: move MAP_SYNC to asm-generic/mman-common.h mm/mmap: move common defines to mman-common.h Subsystem: mm:pagemap Robin Murphy <robin.murphy@xxxxxxx>: mm: clean up is_device_*_page() definitions mm: introduce ARCH_HAS_PTE_DEVMAP arm64: mm: implement pte_devmap support Subsystem: mm:cleanups Daniel Jordan <daniel.m.jordan@xxxxxxxxxx>: mm: add account_locked_vm utility function Subsystem: cleanups "Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx>: fs/select.c: use struct_size() in kmalloc()