incoming

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am experimenting with splitting MM up into identifiable subsystems
perhaps with a view to gitifying it in complex ways.  Also with more
verbose "incoming" emails.

Most of MM is here and a few other trees.

147 patches, based on 753c8d9b7d81206bb5d011b28abe829d364b028e


Subsystems affected by this patch series:

  hotfixes
  iommu
  scripts
  arch/sh
  ocfs2
  mm:slab-generic
  mm:slub
  mm:kmemleak
  mm:kasan
  mm:cleanups
  mm:debug
  mm:pagecache
  mm:swap
  mm:memcg
  mm:gup
  mm:pagemap
  mm:infrastructure
  mm:vmalloc
  mm:initialization
  mm:pagealloc
  mm:vmscan
  mm:tools
  mm:proc
  mm:ras
  mm:oom-kill

Subsystem: hotfixes

    Kuo-Hsin Yang <vovoy@xxxxxxxxxxxx>:
      mm: vmscan: scan anonymous pages on file refaults

    "Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxxxxxx>:
      mm/nvdimm: add is_ioremap_addr and use that to check ioremap address

    Yafang Shao <laoar.shao@xxxxxxxxx>:
      mm/memcontrol: fix wrong statistics in memory.stat

    Henry Burns <henryburns@xxxxxxxxxx>:
      mm/z3fold.c: lock z3fold page before  __SetPageMovable()

    Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx>:
      nilfs2: do not use unexported cpu_to_le32()/le32_to_cpu() in uapi header

    Ryusuke Konishi <konishi.ryusuke@xxxxxxxxx>:
      MAINTAINERS: nilfs2: update email address

Subsystem: iommu

    Qian Cai <cai@xxxxxx>:
      include/linux/dmar.h: replace single-char identifiers in macros

Subsystem: scripts

    Nicolas Boichat <drinkcat@xxxxxxxxxxxx>:
      scripts/decode_stacktrace: match basepath using shell prefix operator, not regex
      scripts/decode_stacktrace: look for modules with .ko.debug extension

    Paul Walmsley <paul.walmsley@xxxxxxxxxx>:
      scripts/spelling.txt: drop "sepc" from the misspelling list

    Chris Paterson <chris.paterson2@xxxxxxxxxxx>:
      scripts/spelling.txt: add spelling fix for prohibited

    Evan Green <evgreen@xxxxxxxxxxxx>:
      scripts/decode_stacktrace: Accept dash/underscore in modules

    Colin Ian King <colin.king@xxxxxxxxxxxxx>:
      scripts/spelling.txt: add more spellings to spelling.txt

Subsystem: arch/sh

    Kefeng Wang <wangkefeng.wang@xxxxxxxxxx>:
      arch/sh/configs/sdk7786_defconfig: remove CONFIG_LOGFS

    Krzysztof Kozlowski <krzk@xxxxxxxxxx>:
      sh: config: remove left-over BACKLIGHT_LCD_SUPPORT

    Sam Ravnborg <sam@xxxxxxxxxxxx>:
      sh: prevent warnings when using iounmap

Subsystem: ocfs2

    ChenGang <cg.chen@xxxxxxxxxx>:
      fs: ocfs: fix spelling mistake "hearbeating" -> "heartbeat"

    "Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx>:
      ocfs2/dlm: use struct_size() helper

    Gang He <ghe@xxxxxxxx>:
      ocfs2: add last unlock times in locking_state
      ocfs2: add locking filter debugfs file
      ocfs2: add first lock wait time in locking_state

    Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>:
      ocfs: no need to check return value of debugfs_create functions

    Hariprasad Kelam <hariprasad.kelam@xxxxxxxxx>:
      fs/ocfs2/dlmglue.c: unneeded variable: "status"

    Fuqian Huang <huangfq.daxian@xxxxxxxxx>:
      ocfs2: use kmemdup rather than duplicating its implementation

Subsystem: mm:slab-generic

    Kees Cook <keescook@xxxxxxxxxxxx>:
    Patch series "mm/slab: Improved sanity checking":
      mm/slab: validate cache membership under freelist hardening
      mm/slab: sanity-check page type when looking up cache
      lkdtm/heap: add tests for freelist hardening

Subsystem: mm:slub

    Yury Norov <yury.norov@xxxxxxxxx>:
      mm/slub.c: avoid double string traverse in kmem_cache_flags()

    Shakeel Butt <shakeelb@xxxxxxxxxx>:
      slub: don't panic for memcg kmem cache creation failure

Subsystem: mm:kmemleak

    Dmitry Vyukov <dvyukov@xxxxxxxxxx>:
      mm/kmemleak.c: fix check for softirq context

    André Almeida <andrealmeid@xxxxxxxxxxxxx>:
      mm/kmemleak.c: change error at _write when kmemleak is disabled
      docs: kmemleak: add more documentation details

Subsystem: mm:kasan

    Marco Elver <elver@xxxxxxxxxx>:
      mm/kasan: print frame description for stack bugs
    Patch series "Bitops instrumentation for KASAN", v5:
      lib/test_kasan: add bitops tests
      x86: use static_cpu_has in uaccess region to avoid instrumentation
      asm-generic, x86: add bitops instrumentation for KASAN
    Patch series "mm/kasan: Add object validation in ksize()", v3:
      mm/kasan: introduce __kasan_check_{read,write}
      mm/kasan: change kasan_check_{read,write} to return boolean
      lib/test_kasan: Add test for double-kzfree detection
      mm/slab: refactor common ksize KASAN logic into slab_common.c
      mm/kasan: add object validation in ksize()

Subsystem: mm:cleanups

    Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>:
      include/linux/pfn_t.h: remove pfn_t_to_virt()

    Mike Rapoport <rppt@xxxxxxxxxxxxx>:
    Patch series "remove ARCH_SELECT_MEMORY_MODEL where it has no effect":
      arm: remove ARCH_SELECT_MEMORY_MODEL
      s390: remove ARCH_SELECT_MEMORY_MODEL
      sparc: remove ARCH_SELECT_MEMORY_MODEL

    Bharath Vedartham <linux.bhar@xxxxxxxxx>:
      mm/gup.c: make follow_page_mask() static

    Miklos Szeredi <miklos@xxxxxxxxxx>:
      mm/memory.c: trivial clean up in insert_page()

    Jason Gunthorpe <jgg@xxxxxxxxxxxx>:
      mm: make !CONFIG_HUGE_PAGE wrappers into static inlines

    Alexey Dobriyan <adobriyan@xxxxxxxxx>:
      include/linux/mm_types.h: ifdef struct vm_area_struct::swap_readahead_info

    Christoph Hellwig <hch@xxxxxx>:
      mm: remove the account_page_dirtied export

    Pingfan Liu <kernelfans@xxxxxxxxx>:
      mm/page_isolation.c: change the prototype of undo_isolate_page_range()

    Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx>:
      include/linux/vmpressure.h: use spinlock_t instead of struct spinlock

    Denis Efremov <efremov@xxxxxxxxx>:
      mm: remove the exporting of totalram_pages

    Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>:
      include/linux/pagemap.h: document trylock_page() return value

Subsystem: mm:debug

    Nicolas Boichat <drinkcat@xxxxxxxxxxxx>:
      mm/failslab.c: by default, do not fail allocations with direct reclaim only

    Vlastimil Babka <vbabka@xxxxxxx>:
    Patch series "debug_pagealloc improvements":
      mm, debug_pagelloc: use static keys to enable debugging
      mm, page_alloc: more extensive free page checking with debug_pagealloc
      mm, debug_pagealloc: use a page type instead of page_ext flag

Subsystem: mm:pagecache

    Christoph Hellwig <hch@xxxxxx>:
    Patch series "fix filler_t callback type mismatches", v2:
      mm/filemap.c: fix an overly long line in read_cache_page
      mm/filemap: don't cast ->readpage to filler_t for do_read_cache_page
      jffs2: pass the correct prototype to read_cache_page
      9p: pass the correct prototype to read_cache_page

    Yang Shi <yang.shi@xxxxxxxxxxxxxxxxx>:
      mm/filemap.c: correct the comment about VM_FAULT_RETRY

Subsystem: mm:swap

    Huang Ying <ying.huang@xxxxxxxxx>:
      mm, swap: fix race between swapoff and some swap operations
      mm/swap_state.c: simplify total_swapcache_pages() with get_swap_device()

    Aaron Lu <ziqian.lzq@xxxxxxxxxx>:
      mm, swap: use rbtree for swap_extent

    Huang Ying <ying.huang@xxxxxxxxx>:
      mm/mincore.c: fix race between swapoff and mincore

Subsystem: mm:memcg

    Shakeel Butt <shakeelb@xxxxxxxxxx>:
      memcg, oom: no oom-kill for __GFP_RETRY_MAYFAIL
      memcg, fsnotify: no oom-kill for remote memcg charging
      mm, memcg: introduce memory.events.local

    Johannes Weiner <hannes@xxxxxxxxxxx>:
      mm: memcontrol: dump memory.stat during cgroup OOM

    Roman Gushchin <guro@xxxxxx>:
    Patch series "mm: reparent slab memory on cgroup removal", v7:
      mm: memcg/slab: postpone kmem_cache memcg pointer initialization to memcg_link_cache()
      mm: memcg/slab: rename slab delayed deactivation functions and fields
      mm: memcg/slab: generalize postponed non-root kmem_cache deactivation
      mm: memcg/slab: introduce __memcg_kmem_uncharge_memcg()
      mm: memcg/slab: unify SLAB and SLUB page accounting
      mm: memcg/slab: don't check the dying flag on kmem_cache creation
      mm: memcg/slab: synchronize access to kmem_cache dying flag using a spinlock
      mm: memcg/slab: rework non-root kmem_cache lifecycle management
      mm: memcg/slab: stop setting page->mem_cgroup pointer for slab pages
      mm: memcg/slab: reparent memcg kmem_caches on cgroup removal

    Waiman Long <longman@xxxxxxxxxx>:
      mm, memcg: add a memcg_slabinfo debugfs file

Subsystem: mm:gup

    Christoph Hellwig <hch@xxxxxx>:
    Patch series "switch the remaining architectures to use generic GUP", v4:
      mm: use untagged_addr() for get_user_pages_fast addresses
      mm: simplify gup_fast_permitted
      mm: lift the x86_32 PAE version of gup_get_pte to common code
      MIPS: use the generic get_user_pages_fast code
      sh: add the missing pud_page definition
      sh: use the generic get_user_pages_fast code
      sparc64: add the missing pgd_page definition
      sparc64: define untagged_addr()
      sparc64: use the generic get_user_pages_fast code
      mm: rename CONFIG_HAVE_GENERIC_GUP to CONFIG_HAVE_FAST_GUP
      mm: reorder code blocks in gup.c
      mm: consolidate the get_user_pages* implementations
      mm: validate get_user_pages_fast flags
      mm: move the powerpc hugepd code to mm/gup.c
      mm: switch gup_hugepte to use try_get_compound_head
      mm: mark the page referenced in gup_hugepte

    Pingfan Liu <kernelfans@xxxxxxxxx>:
      mm/gup: speed up check_and_migrate_cma_pages() on huge page

    Andy Lutomirski <luto@xxxxxxxxxx>:
      mm/gup.c: remove some BUG_ONs from get_gate_page()

    Guenter Roeck <linux@xxxxxxxxxxxx>:
      mm/gup.c: mark undo_dev_pagemap as __maybe_unused

Subsystem: mm:pagemap

    Mike Rapoport <rppt@xxxxxxxxxxxxx>:
      asm-generic, x86: introduce generic pte_{alloc,free}_one[_kernel]
      alpha: switch to generic version of pte allocation
      arm: switch to generic version of pte allocation
      arm64: switch to generic version of pte allocation
      csky: switch to generic version of pte allocation
      m68k: sun3: switch to generic version of pte allocation
      mips: switch to generic version of pte allocation
      nds32: switch to generic version of pte allocation
      nios2: switch to generic version of pte allocation
      parisc: switch to generic version of pte allocation
      riscv: switch to generic version of pte allocation
      um: switch to generic version of pte allocation
      unicore32: switch to generic version of pte allocation

    Anshuman Khandual <anshuman.khandual@xxxxxxx>:
      mm/pgtable: drop pgtable_t variable from pte_fn_t functions

    Miguel Ojeda <miguel.ojeda.sandonis@xxxxxxxxx>:
      mm/memory.c: fail when offset == num in first check of __vm_map_pages()

Subsystem: mm:infrastructure

    Jean-Philippe Brucker <jean-philippe.brucker@xxxxxxx>:
      mm/mmu_notifier: use hlist_add_head_rcu()

Subsystem: mm:vmalloc

    "Uladzislau Rezki (Sony)" <urezki@xxxxxxxxx>:
    Patch series "Some cleanups for the KVA/vmalloc", v5:
      mm/vmalloc.c: remove "node" argument
      mm/vmalloc.c: preload a CPU with one object for split purpose
      mm/vmalloc.c: get rid of one single unlink_va() when merge
      mm/vmalloc.c: switch to WARN_ON() and move it under unlink_va()

    Geert Uytterhoeven <geert+renesas@xxxxxxxxx>:
      mm/vmalloc.c: spelling> s/informaion/information/

Subsystem: mm:initialization

    Nicholas Piggin <npiggin@xxxxxxxxx>:
      mm/large system hash: use vmalloc for size > MAX_ORDER when !hashdist
      mm/large system hash: clear hashdist when only one node with memory is booted

Subsystem: mm:pagealloc

    Kees Cook <keescook@xxxxxxxxxxxx>:
      arm64: move jump_label_init() before parse_early_param()

    Alexander Potapenko <glider@xxxxxxxxxx>:
    Patch series "add init_on_alloc/init_on_free boot options", v10:
      mm: security: introduce init_on_alloc=1 and init_on_free=1 boot options
      mm: init: report memory auto-initialization features at boot time

Subsystem: mm:vmscan

    Yang Shi <yang.shi@xxxxxxxxxxxxxxxxx>:
      mm: vmscan: remove double slab pressure by inc'ing sc->nr_scanned
      mm: vmscan: correct some vmscan counters for THP swapout

Subsystem: mm:tools

    "Tobin C. Harding" <tobin@xxxxxxxxxx>:
      tools/vm/slabinfo: order command line options
      tools/vm/slabinfo: add partial slab listing to -X
      tools/vm/slabinfo: add option to sort by partial slabs
      tools/vm/slabinfo: add sorting info to help menu

Subsystem: mm:proc

    Konstantin Khlebnikov <khlebnikov@xxxxxxxxxxxxxx>:
      proc: use down_read_killable mmap_sem for /proc/pid/maps
      proc: use down_read_killable mmap_sem for /proc/pid/smaps_rollup
      proc: use down_read_killable mmap_sem for /proc/pid/pagemap
      proc: use down_read_killable mmap_sem for /proc/pid/clear_refs
      proc: use down_read_killable mmap_sem for /proc/pid/map_files
      mm: use down_read_killable for locking mmap_sem in access_remote_vm

    Luigi Semenzato <semenzato@xxxxxxxxxxxx>:
      mm: smaps: split PSS into components

    Roman Gushchin <guro@xxxxxx>:
      mm: vmalloc: show number of vmalloc pages in /proc/meminfo

Subsystem: mm:ras

    Jane Chu <jane.chu@xxxxxxxxxx>:
      mm/memory-failure.c: clarify error message

Subsystem: mm:oom-kill

    Tetsuo Handa <penguin-kernel@xxxxxxxxxxxxxxxxxxx>:
      mm: memcontrol: use CSS_TASK_ITER_PROCS at mem_cgroup_scan_tasks()

    Shakeel Butt <shakeelb@xxxxxxxxxx>:
      mm, oom: refactor dump_tasks for memcg OOMs
      mm, oom: remove redundant task_in_mem_cgroup() check
      oom: decouple mems_allowed from oom_unkillable_task

    Tetsuo Handa <penguin-kernel@xxxxxxxxxxxxxxxxxxx>:
      mm/oom_kill.c: remove redundant OOM score normalization in select_bad_process()





[Index of Archives]     [Kernel Archive]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]

  Powered by Linux