The patch titled Subject: power: wakeup: remove use of seq_printf return value has been removed from the -mm tree. Its filename was power-wakeup-remove-use-of-seq_printf-return-value.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Joe Perches <joe@xxxxxxxxxxx> Subject: power: wakeup: remove use of seq_printf return value The seq_printf return value, because it's frequently misused, will eventually be converted to void. See: commit 1f33c41c03da ("seq_file: Rename seq_overflow() to seq_has_overflowed() and make public") Signed-off-by: Joe Perches <joe@xxxxxxxxxxx> Cc: "Rafael J. Wysocki" <rjw@xxxxxxxxxxxxx> Cc: Pavel Machek <pavel@xxxxxx> Cc: Len Brown <len.brown@xxxxxxxxx> Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- drivers/base/power/wakeup.c | 16 +++++++--------- 1 file changed, 7 insertions(+), 9 deletions(-) diff -puN drivers/base/power/wakeup.c~power-wakeup-remove-use-of-seq_printf-return-value drivers/base/power/wakeup.c --- a/drivers/base/power/wakeup.c~power-wakeup-remove-use-of-seq_printf-return-value +++ a/drivers/base/power/wakeup.c @@ -843,7 +843,6 @@ static int print_wakeup_source_stats(str unsigned long active_count; ktime_t active_time; ktime_t prevent_sleep_time; - int ret; spin_lock_irqsave(&ws->lock, flags); @@ -866,17 +865,16 @@ static int print_wakeup_source_stats(str active_time = ktime_set(0, 0); } - ret = seq_printf(m, "%-12s\t%lu\t\t%lu\t\t%lu\t\t%lu\t\t" - "%lld\t\t%lld\t\t%lld\t\t%lld\t\t%lld\n", - ws->name, active_count, ws->event_count, - ws->wakeup_count, ws->expire_count, - ktime_to_ms(active_time), ktime_to_ms(total_time), - ktime_to_ms(max_time), ktime_to_ms(ws->last_time), - ktime_to_ms(prevent_sleep_time)); + seq_printf(m, "%-12s\t%lu\t\t%lu\t\t%lu\t\t%lu\t\t%lld\t\t%lld\t\t%lld\t\t%lld\t\t%lld\n", + ws->name, active_count, ws->event_count, + ws->wakeup_count, ws->expire_count, + ktime_to_ms(active_time), ktime_to_ms(total_time), + ktime_to_ms(max_time), ktime_to_ms(ws->last_time), + ktime_to_ms(prevent_sleep_time)); spin_unlock_irqrestore(&ws->lock, flags); - return ret; + return 0; } /** _ Patches currently in -mm which might be from joe@xxxxxxxxxxx are origin.patch ocfs2-neaten-do_error-ocfs2_error-and-ocfs2_abort.patch lib-vsprintfc-even-faster-decimal-conversion.patch mm-utilc-add-kstrimdup.patch checkpatch-improve-no-space-is-necessary-after-a-cast-test.patch checkpatch-add-spell-checking-of-email-subject-line.patch checkpatch-spell-check-reudce.patch checkpatch-add-optional-codespell-dictionary-to-find-more-typos.patch checkpatch-match-more-world-writable-permissions.patch checkpatch-match-more-world-writable-permissions-fix.patch checkpatch-improve-return-negative-errno-check.patch checkpatch-add-test-for-repeated-const-uses.patch checkpatch-dont-ask-for-asm-fileh-to-linux-fileh-unconditionally.patch checkpatch-submittingpatches-suggest-line-wrapping-commit-messages-at-75-columns.patch checkpatch-add-define-foo-string-long-line-exception.patch checkpatch-add-uart_ops-to-normally-const-structs.patch checkpatch-add-prefer-array_size-test.patch checkpatch-improve-operator-spacing-check.patch checkpatch-add-a-test-for-const-with-__read_mostly-uses.patch checkpatchpl-new-instances-of-enosys-are-errors.patch errnoh-improve-enosyss-comment.patch checkpatch-fix-fix-use-with-a-patch-of-multiple-files.patch checkpatch-avoid-spaces-required-around-that-false-positive.patch rtc-use-more-standard-kernel-logging-styles.patch adfs-returning-correct-return-values.patch linux-next.patch proc-show-locks-in-proc-pid-fdinfo-x.patch proc-show-locks-in-proc-pid-fdinfo-x-v2.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html