The patch titled Subject: x86: mtrr: if: remove use of seq_printf return value has been removed from the -mm tree. Its filename was x86-mtrr-if-remove-use-of-seq_printf-return-value.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Joe Perches <joe@xxxxxxxxxxx> Subject: x86: mtrr: if: remove use of seq_printf return value The seq_printf return value, because it's frequently misused, will eventually be converted to void. See: commit 1f33c41c03da ("seq_file: Rename seq_overflow() to seq_has_overflowed() and make public") Signed-off-by: Joe Perches <joe@xxxxxxxxxxx> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> Cc: Ingo Molnar <mingo@xxxxxxxxxx> Cc: "H. Peter Anvin" <hpa@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- arch/x86/kernel/cpu/mtrr/if.c | 12 +++++------- 1 file changed, 5 insertions(+), 7 deletions(-) diff -puN arch/x86/kernel/cpu/mtrr/if.c~x86-mtrr-if-remove-use-of-seq_printf-return-value arch/x86/kernel/cpu/mtrr/if.c --- a/arch/x86/kernel/cpu/mtrr/if.c~x86-mtrr-if-remove-use-of-seq_printf-return-value +++ a/arch/x86/kernel/cpu/mtrr/if.c @@ -404,11 +404,10 @@ static const struct file_operations mtrr static int mtrr_seq_show(struct seq_file *seq, void *offset) { char factor; - int i, max, len; + int i, max; mtrr_type type; unsigned long base, size; - len = 0; max = num_var_ranges; for (i = 0; i < max; i++) { mtrr_if->get(i, &base, &size, &type); @@ -425,11 +424,10 @@ static int mtrr_seq_show(struct seq_file size >>= 20 - PAGE_SHIFT; } /* Base can be > 32bit */ - len += seq_printf(seq, "reg%02i: base=0x%06lx000 " - "(%5luMB), size=%5lu%cB, count=%d: %s\n", - i, base, base >> (20 - PAGE_SHIFT), size, - factor, mtrr_usage_table[i], - mtrr_attrib_to_str(type)); + seq_printf(seq, "reg%02i: base=0x%06lx000 (%5luMB), size=%5lu%cB, count=%d: %s\n", + i, base, base >> (20 - PAGE_SHIFT), + size, factor, + mtrr_usage_table[i], mtrr_attrib_to_str(type)); } return 0; } _ Patches currently in -mm which might be from joe@xxxxxxxxxxx are origin.patch ocfs2-neaten-do_error-ocfs2_error-and-ocfs2_abort.patch lib-vsprintfc-even-faster-decimal-conversion.patch mm-utilc-add-kstrimdup.patch checkpatch-improve-no-space-is-necessary-after-a-cast-test.patch checkpatch-add-spell-checking-of-email-subject-line.patch checkpatch-spell-check-reudce.patch checkpatch-add-optional-codespell-dictionary-to-find-more-typos.patch checkpatch-match-more-world-writable-permissions.patch checkpatch-match-more-world-writable-permissions-fix.patch checkpatch-improve-return-negative-errno-check.patch checkpatch-add-test-for-repeated-const-uses.patch checkpatch-dont-ask-for-asm-fileh-to-linux-fileh-unconditionally.patch checkpatch-submittingpatches-suggest-line-wrapping-commit-messages-at-75-columns.patch checkpatch-add-define-foo-string-long-line-exception.patch checkpatch-add-uart_ops-to-normally-const-structs.patch checkpatch-add-prefer-array_size-test.patch checkpatch-improve-operator-spacing-check.patch checkpatch-add-a-test-for-const-with-__read_mostly-uses.patch checkpatchpl-new-instances-of-enosys-are-errors.patch errnoh-improve-enosyss-comment.patch checkpatch-fix-fix-use-with-a-patch-of-multiple-files.patch checkpatch-avoid-spaces-required-around-that-false-positive.patch rtc-use-more-standard-kernel-logging-styles.patch adfs-returning-correct-return-values.patch linux-next.patch proc-show-locks-in-proc-pid-fdinfo-x.patch proc-show-locks-in-proc-pid-fdinfo-x-v2.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html