On Tue, Jun 20, 2017 at 7:34 AM, Stephen Boyd <sboyd@xxxxxxxxxxxxxx> wrote: > On 06/16, Binbin Zhou wrote: >> diff --git a/drivers/clk/loongson1/clk-loongson1a.c b/drivers/clk/loongson1/clk-loongson1a.c >> new file mode 100644 >> index 0000000..263a82c >> --- /dev/null >> +++ b/drivers/clk/loongson1/clk-loongson1a.c >> @@ -0,0 +1,75 @@ >> +/* >> + * Copyright (c) 2012-2016 Binbin Zhou <zhoubb@xxxxxxxxxx> >> + * >> + * This program is free software; you can redistribute it and/or modify it >> + * under the terms of the GNU General Public License as published by the >> + * Free Software Foundation; either version 2 of the License, or (at your >> + * option) any later version. >> + */ >> + >> +#include <linux/clkdev.h> >> +#include <linux/clk-provider.h> >> +#include <linux/io.h> >> +#include <linux/err.h> >> + >> +#include <loongson1.h> >> +#include "clk.h" >> + >> +#define OSC (33 * 1000000) >> +#define DIV_APB 2 >> + >> +static DEFINE_SPINLOCK(_lock); > > I know the other loongson1*.c files also call it "_lock", but > that's not a very good name for something that may show up in > lockdep debugging error messages. How about something a bit more > descriptive, loongson1x_clk_lock? > It's a good idea! Actually, the variable is not be used in this file. If I rename it in another new patch will be better. Do you think so ? Best wishes! Binbin Zhou > -- > Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, > a Linux Foundation Collaborative Project